Upstream information

CVE-2006-3746 at MITRE

Description

Integer overflow in parse_comment in GnuPG (gpg) 1.4.4 allows remote attackers to cause a denial of service (segmentation fault) via a crafted message.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 195569 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • gpg2 >= 2.0.9-25.25.1
  • gpg2-lang >= 2.0.9-25.25.1
SUSE Linux Enterprise Server 11 SP2
  • gpg2 >= 2.0.9-25.33.27.1
  • gpg2-lang >= 2.0.9-25.33.27.1
SUSE Linux Enterprise Server 11 SP3
  • gpg2 >= 2.0.9-25.33.31.1
  • gpg2-lang >= 2.0.9-25.33.31.1
SUSE Linux Enterprise Server 11 SP4
  • gpg2 >= 2.0.9-25.33.39.1
  • gpg2-lang >= 2.0.9-25.33.39.1
openSUSE Tumbleweed
  • dirmngr >= 2.2.27-2.4
  • gpg2 >= 2.2.27-2.4
  • gpg2-lang >= 2.2.27-2.4
Patchnames:
openSUSE Tumbleweed GA dirmngr-2.2.27-2.4