Upstream information

CVE-2006-3121 at MITRE

Description

The peel_netstring function in cl_netstring.c in the heartbeat subsystem in High-Availability Linux before 1.2.5, and 2.0 before 2.0.7, allows remote attackers to cause a denial of service (crash) via the length parameter in a heartbeat message.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 195068 [RESOLVED / WONTFIX]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
Open Enterprise Server
  • heartbeat >= 1.2.5-0.3
  • heartbeat-ldirectord >= 1.2.5-0.3
  • heartbeat-pils >= 1.2.5-0.3
  • heartbeat-stonith >= 1.2.5-0.3
core9.s390
core9.x86
YOU Patch Nr: 11758
SUSE LINUX 10.1
  • heartbeat >= 2.0.7-1.3
  • heartbeat-cmpi >= 2.0.7-1.3
  • heartbeat-ldirectord >= 2.0.7-1.3
  • heartbeat-pils >= 2.0.7-1.3
  • heartbeat-stonith >= 2.0.7-1.3
SUSE Linux Enterprise Server 10 SP1 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP1 for IBM POWER
SUSE Linux Enterprise Server 10 SP1 for IBM zSeries 64bit
SUSE Linux Enterprise Server 10 SP1 for IPF
SUSE Linux Enterprise Server 10 SP1 for x86
  • drbd >= 0.7.22-42.11
  • heartbeat >= 2.0.8-0.19
  • heartbeat-cmpi >= 2.0.8-0.19
  • heartbeat-ldirectord >= 2.0.8-0.19
  • heartbeat-pils >= 2.0.8-0.19
  • heartbeat-stonith >= 2.0.8-0.19
  • ocfs2-tools >= 1.2.3-0.7
  • ocfs2console >= 1.2.3-0.7
sles10.x86
sles10.s390x
ZYPP Patch Nr: 2764