Upstream information

CVE-2006-3082 at MITRE

Description

parse-packet.c in GnuPG (gpg) 1.4.3 and 1.9.20, and earlier versions, allows remote attackers to cause a denial of service (gpg crash) and possibly overwrite memory via a message packet with a large length (long user ID string), which could lead to an integer overflow, as demonstrated using the --no-armor option.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 180615 [RESOLVED / INVALID]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SuSE Linux Desktop 1.0
  • gpg >= 1.2.2rc1-120
ul1.x86-64
ul1.ppc
sles9-oes.x86
core9.ia64
core9.s390
core9.ppc
slrs8.x86
ul1.ia64
ul1.s390
core9.x86-64
YOU Patch Nr: 11073
SUSE LINUX Retail Solution 8
SuSE Linux Enterprise Server 8 for AMD64
SuSE Linux Enterprise Server 8 for IBM iSeries and IBM pSeries
SuSE Linux Enterprise Server 8 for IBM zSeries
SuSE Linux Enterprise Server 8 for IPF
SuSE Linux Openexchange Server 4
SuSE Linux School Server for i386
SuSE Linux Standard Server 8
UnitedLinux 1.0
  • gpg >= 1.0.7-185
ul1.x86-64
ul1.ppc
sles9-oes.x86
core9.ia64
core9.s390
core9.ppc
slrs8.x86
ul1.ia64
ul1.s390
core9.x86-64
YOU Patch Nr: 11073
Novell Linux Desktop 9 for x86
Novell Linux Desktop 9 for x86_64
Open Enterprise Server
  • gpg >= 1.2.4-68.16
ul1.x86-64
ul1.ppc
sles9-oes.x86
core9.ia64
core9.s390
core9.ppc
slrs8.x86
ul1.ia64
ul1.s390
core9.x86-64
YOU Patch Nr: 11073
SUSE LINUX 10.0
  • gpg >= 1.4.2-5.6
SUSE LINUX 10.1
  • gpg >= 1.4.2-23.4
SUSE LINUX 9.1 for IA32
SUSE LINUX 9.1 for x86-64
  • gpg >= 1.2.4-68.16
SUSE LINUX 9.2
  • gpg >= 1.2.5-3.8
SUSE LINUX 9.3
  • gpg >= 1.4.0-4.6
SUSE LINUX 10.0
  • gpg2 >= 1.9.18-2.6
SUSE LINUX 10.1
  • gpg2 >= 1.9.18-17.5
SUSE LINUX 9.2
  • gpg2 >= 1.9.10-3.8
SUSE LINUX 9.3
  • gpg2 >= 1.9.14-6.8
Novell Linux Desktop 9 for x86
Novell Linux Desktop 9 for x86_64
  • gpg2 >= 1.9.10-2.6
Builds
ZYPP Patch Nr: 1834