Upstream information

CVE-2006-1518 at MITRE

Description

Buffer overflow in the open_table function in sql_base.cc in MySQL 5.0.x up to 5.0.20 might allow remote attackers to execute arbitrary code via crafted COM_TABLE_DUMP packets with invalid length values.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.5
Vector AV:N/AC:L/Au:S/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 172155 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE LINUX 9.1 for IA32
SUSE LINUX 9.1 for x86-64
  • mysql-Max >= 4.0.18-32.26
SUSE LINUX 9.2
  • mysql-Max >= 4.0.21-4.8
SUSE LINUX 9.3
  • mysql-Max >= 4.1.10a-3.6
SUSE LINUX Retail Solution 8
SuSE Linux Enterprise Server 8 for AMD64
SuSE Linux Enterprise Server 8 for IBM iSeries and IBM pSeries
SuSE Linux Enterprise Server 8 for IBM zSeries
SuSE Linux Enterprise Server 8 for IPF
SuSE Linux Openexchange Server 4
SuSE Linux School Server for i386
SuSE Linux Standard Server 8
UnitedLinux 1.0
  • mysql >= 3.23.52-132
Builds
YOU Patch Nr: 10985
Novell Linux Desktop 9 for x86
Novell Linux Desktop 9 for x86_64
Open Enterprise Server
  • mysql >= 4.0.18-32.23
Builds
YOU Patch Nr: 10985
Novell Linux Desktop 9 for x86
Novell Linux Desktop 9 for x86_64
Open Enterprise Server
  • mysql-Max >= 4.0.18-32.26
Builds
YOU Patch Nr: 11058
SUSE LINUX 10.0
  • mysql >= 4.1.13-3.4
SUSE LINUX 10.1
  • mysql >= 5.0.18-16.1
SUSE LINUX 9.1 for IA32
SUSE LINUX 9.1 for x86-64
  • mysql >= 4.0.18-32.23
SUSE LINUX 9.2
  • mysql >= 4.0.21-4.8
SUSE LINUX 9.3
  • mysql >= 4.1.10a-3.6