Upstream information

CVE-2006-0646 at MITRE

Description

ld in SUSE Linux 9.1 through 10.0, and SLES 9, in certain circumstances when linking binaries, can leave an empty RPATH or RUNPATH, which allows local attackers to execute arbitrary code as other users via by running an ld-linked application from the current directory, which could contain an attacker-controlled library file.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.4
Vector AV:L/AC:M/Au:N/C:P/I:P/A:P
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 141210 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE LINUX 10.0
  • binutils >= 2.16.91.0.2-8.4
  • binutils-32bit >= 2.16.91.0.2-8.4
  • binutils-64bit >= 2.16.91.0.2-8.4
SUSE LINUX 9.1 for IA32
  • binutils >= 2.15.90.0.1.1-32.13
SUSE LINUX 9.1 for x86-64
  • binutils >= 2.15.90.0.1.1-32.13
  • binutils-32bit >= 9.1-200601211731
SUSE LINUX 9.2
  • binutils >= 2.15.91.0.2-7.3
  • binutils-32bit >= 9.2-200601220214
SUSE LINUX 9.3
  • binutils >= 2.15.94.0.2.2-3.3
  • binutils-32bit >= 9.3-7.1
Novell Linux Desktop 9 for x86
Novell Linux Desktop 9 for x86_64
  • dia >= 0.94-13.5
core9.ppc
core9.ia64
core9.s390
core9.x86
YOU Patch Nr: 10849
SLES SDK 9 for IBM S/390 and IBM zSeries
SLES SDK 9 for IBM iSeries and IBM pSeries
SLES SDK 9 for IBM zSeries
SLES SDK 9 for IPF
SLES SDK 9 for X86-64
SLES SDK 9 for x86
  • dia >= 0.92.2-112.11
core9.ppc
core9.ia64
core9.s390
core9.x86
YOU Patch Nr: 10849
Novell Linux Desktop 9 for x86
Open Enterprise Server
  • binutils >= 2.15.90.0.1.1-32.13
sles9-nlpos.x86
core9.s390
core9.ia64
core9.ppc
core9.x86-64
YOU Patch Nr: 10824
Novell Linux Desktop 9 for x86_64
  • binutils >= 2.15.90.0.1.1-32.13
  • binutils-32bit >= 9-200601210802
sles9-nlpos.x86
core9.s390
core9.ia64
core9.ppc
core9.x86-64
YOU Patch Nr: 10824
SUSE LINUX 10.0
  • kdelibs3 >= 3.4.2-24.3
  • kdelibs3-32bit >= 3.4.2-24.3
  • kdelibs3-64bit >= 3.4.2-24.3
  • kdelibs3-devel >= 3.4.2-24.3
SUSE LINUX 9.1 for IA32
  • kdelibs3 >= 3.2.1-44.66
  • kdelibs3-devel >= 3.2.1-44.66
SUSE LINUX 9.1 for x86-64
  • kdelibs3 >= 3.2.1-44.66
  • kdelibs3-32bit >= 9.1-200601261432
  • kdelibs3-devel >= 3.2.1-44.66
SUSE LINUX 9.2
  • kdelibs3 >= 3.3.0-34.12
  • kdelibs3-32bit >= 9.2-200602011857
  • kdelibs3-devel >= 3.3.0-34.12
SUSE LINUX 9.3
  • kdelibs3 >= 3.4.0-20.11
  • kdelibs3-32bit >= 9.3-7.5
  • kdelibs3-devel >= 3.4.0-20.11
SUSE LINUX 10.0
  • kdegraphics3 >= 3.4.2-12.2
  • kdegraphics3-3D >= 3.4.2-12.2
  • kdegraphics3-imaging >= 3.4.2-12.2
  • kdegraphics3-scan >= 3.4.2-12.2
  • kdegraphics3-tex >= 3.4.2-12.2
SUSE LINUX 9.2
  • kdegraphics3 >= 3.3.0-13.7
  • kdegraphics3-3D >= 3.3.0-13.7
  • kdegraphics3-imaging >= 3.3.0-13.7
  • kdegraphics3-scan >= 3.3.0-13.7
  • kdegraphics3-tex >= 3.3.0-13.7
SUSE LINUX 9.3
  • kdegraphics3 >= 3.4.0-11.5
  • kdegraphics3-3D >= 3.4.0-11.5
  • kdegraphics3-imaging >= 3.4.0-11.5
  • kdegraphics3-scan >= 3.4.0-11.5
  • kdegraphics3-tex >= 3.4.0-11.5
SUSE LINUX 10.0
  • lyx >= 1.3.6-3.1
SUSE LINUX 9.2
  • lyx >= 1.3.4-38.1
SUSE LINUX 9.3
  • lyx >= 1.3.5-3.1