Upstream information

CVE-2006-0043 at MITRE

Description

Buffer overflow in the realpath function in nfs-server rpc.mountd, as used in SUSE Linux 9.1 through 10.0, allows local users to execute arbitrary code via unspecified vectors involving mount requests and symlinks.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.6
Vector AV:L/AC:L/Au:N/C:P/I:P/A:P
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 142824 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE LINUX 10.0
  • nfs-server >= 2.2beta51-212.2
SUSE LINUX 9.1 for IA32
SUSE LINUX 9.1 for x86-64
  • nfs-server >= 2.2beta51-206.4
SUSE LINUX 9.2
  • nfs-server >= 2.2beta51-208.2
SUSE LINUX 9.3
  • nfs-server >= 2.2beta51-209.2