Upstream information

CVE-2005-3350 at MITRE

Description

libungif library before 4.1.0 allows attackers to corrupt memory and possibly execute arbitrary code via a crafted GIF file that leads to an out-of-bounds write.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 129927 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE LINUX Retail Solution 8
SuSE Linux Desktop 1.0
SuSE Linux Enterprise Server 8 for AMD64
SuSE Linux Enterprise Server 8 for IBM iSeries and IBM pSeries
SuSE Linux Enterprise Server 8 for IBM zSeries
SuSE Linux Enterprise Server 8 for IPF
SuSE Linux Openexchange Server 4
SuSE Linux School Server for i386
SuSE Linux Standard Server 8
UnitedLinux 1.0
  • libungif >= 4.1.0b1-587
core9.s390
sles9-oes.x86
core9.ppc
core9.ia64
core9.x86-64
slox4,2.x86
YOU Patch Nr: 10556
Novell Linux Desktop 9 for x86
Novell Linux Desktop 9 for x86_64
Open Enterprise Server
  • libungif >= 4.1.0b1-585.4
core9.s390
sles9-oes.x86
core9.ppc
core9.ia64
core9.x86-64
slox4,2.x86
YOU Patch Nr: 10556
SUSE LINUX 10.0
  • giflib >= 4.1.3-7.2
  • giflib-32bit >= 4.1.3-7.2
  • giflib-64bit >= 4.1.3-7.2
  • giflib-devel >= 4.1.3-7.2
  • giflib-devel-32bit >= 4.1.3-7.2
  • giflib-devel-64bit >= 4.1.3-7.2
SUSE LINUX 9.2
  • giflib >= 4.1.3-4.2
  • giflib-32bit >= 9.2-200511030547
  • giflib-devel >= 4.1.3-4.2
SUSE LINUX 9.3
  • giflib >= 4.1.3-5.2
  • giflib-32bit >= 9.3-7.1
  • giflib-devel >= 4.1.3-5.2
  • giflib-devel-32bit >= 9.3-7.1