Upstream information

CVE-2005-2969 at MITRE

Description

The SSL/TLS server implementation in OpenSSL 0.9.7 before 0.9.7h and 0.9.8 before 0.9.8a, when using the SSL_OP_MSIE_SSLV2_RSA_PADDING option, disables a verification step that is required for preventing protocol version rollback attacks, which allows remote attackers to force a client and server to use a weaker protocol than needed via a man-in-the-middle attack.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entries: 120103, 202366 [RESOLVED / FIXED], 215623 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE LINUX Retail Solution 8
SuSE Linux Enterprise Server 8 for AMD64
SuSE Linux Enterprise Server 8 for IBM iSeries and IBM pSeries
SuSE Linux Enterprise Server 8 for IBM zSeries
SuSE Linux Enterprise Server 8 for IPF
SuSE Linux Openexchange Server 4
SuSE Linux School Server for i386
SuSE Linux Standard Server 8
UnitedLinux 1.0
  • openssl >= 0.9.6g-132
  • openssl-devel >= 0.9.6g-132
core9.ia64
slox4,2.x86
sles9-oes.x86
core9.x86-64
core9.s390
core9.ppc
YOU Patch Nr: 10533
Novell Linux Desktop 9 for x86
Novell Linux Desktop 9 for x86_64
Open Enterprise Server
  • openssl >= 0.9.7d-15.15.3
  • openssl-devel >= 0.9.7d-15.15.3
core9.ia64
slox4,2.x86
sles9-oes.x86
core9.x86-64
core9.s390
core9.ppc
YOU Patch Nr: 10533
SuSE Linux Desktop 1.0
  • openssl >= 0.9.6g-133
Builds
SuSE Linux Enterprise Server 8 for IBM zSeries
  • openssl-z990 >= 0.9.7c-9
ul1.s390
YOU Patch Nr: 11271
SUSE LINUX 10.0
  • openssl >= 0.9.7g-2.2
  • openssl-32bit >= 0.9.7g-2.2
  • openssl-64bit >= 0.9.7g-2.2
  • openssl-devel >= 0.9.7g-2.2
  • openssl-devel-32bit >= 0.9.7g-2.2
  • openssl-devel-64bit >= 0.9.7g-2.2
SuSE Linux 9.0 for IA32
  • openssl >= 0.9.7b-135
  • openssl-devel >= 0.9.7b-135
SuSE Linux 9.0 for AMD64
  • openssl >= 0.9.7b-135
  • openssl-32bit >= 9.0-5
  • openssl-devel >= 0.9.7b-135
  • openssl-devel-32bit >= 9.0-5
SUSE LINUX 9.1 for IA32
  • openssl >= 0.9.7d-15.15.3
  • openssl-devel >= 0.9.7d-15.15.3
SUSE LINUX 9.1 for x86-64
  • openssl >= 0.9.7d-15.15.3
  • openssl-32bit >= 9.1-200510151708
  • openssl-devel >= 0.9.7d-15.15.3
  • openssl-devel-32bit >= 9.1-200510151708
SUSE LINUX 9.2
  • openssl >= 0.9.7d-25.2
  • openssl-32bit >= 9.2-200510160152
  • openssl-devel >= 0.9.7d-25.2
  • openssl-devel-32bit >= 9.2-200510160152
SUSE LINUX 9.3
  • openssl >= 0.9.7e-3.2
  • openssl-32bit >= 9.3-7.1
  • openssl-devel >= 0.9.7e-3.2
  • openssl-devel-32bit >= 9.3-7.1