Upstream information

CVE-2005-2967 at MITRE

Description

Format string vulnerability in input_cdda.c in xine-lib 1-beta through 1-beta 3, 1-rc, 1.0 through 1.0.2, and 1.1.1 allows remote servers to execute arbitrary code via format string specifiers in metadata in CDDB server responses when the victim plays a CD.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 120088 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Novell Linux Desktop 9 for x86
Novell Linux Desktop 9 for x86_64
SLES SDK 9 for IBM S/390 and IBM zSeries
SLES SDK 9 for x86
  • xine-lib >= 0.99.rc3a-106.24
core9.x86-64
core9.ppc
core9.s390
sles9-nld.x86
core9.ia64
YOU Patch Nr: 10525
SLES SDK 9 for IPF
  • xine-lib >= 0.99.rc3a-106.24
  • xine-lib-x86 >= 9-200510111439
core9.x86-64
core9.ppc
core9.s390
sles9-nld.x86
core9.ia64
YOU Patch Nr: 10525
SLES SDK 9 for IBM iSeries and IBM pSeries
  • xine-lib >= 0.99.rc3a-106.24
  • xine-lib-64bit >= 9-200510121243
core9.x86-64
core9.ppc
core9.s390
sles9-nld.x86
core9.ia64
YOU Patch Nr: 10525
SLES SDK 9 for IBM zSeries
  • xine-lib >= 0.99.rc3a-106.24
  • xine-lib-32bit >= 9-200510111435
core9.x86-64
core9.ppc
core9.s390
sles9-nld.x86
core9.ia64
YOU Patch Nr: 10525
SLES SDK 9 for X86-64
  • xine-lib >= 0.99.rc3a-106.24
  • xine-lib-32bit >= 9-200510111441
core9.x86-64
core9.ppc
core9.s390
sles9-nld.x86
core9.ia64
YOU Patch Nr: 10525
SUSE LINUX 10.0
  • xine-lib >= 1.1.0-12.2
  • xine-lib-32bit >= 1.1.0-12.2
  • xine-lib-64bit >= 1.1.0-12.2
SuSE Linux 9.0 for IA32
  • xine-lib >= 0.99.rc0a-123
SuSE Linux 9.0 for AMD64
  • xine-lib >= 0.99.rc0a-123
  • xine-lib-32bit >= 9.0-5
SUSE LINUX 9.1 for IA32
  • xine-lib >= 0.99.rc3a-106.24
SUSE LINUX 9.1 for x86-64
  • xine-lib >= 0.99.rc3a-106.24
  • xine-lib-32bit >= 9.1-200510111459
SUSE LINUX 9.2
  • xine-lib >= 0.99.rc6a-4.6
  • xine-lib-32bit >= 9.2-200510111540
SUSE LINUX 9.3
  • xine-lib >= 1.0-10.4
  • xine-lib-32bit >= 9.3-7.2