Upstream information

CVE-2005-2958 at MITRE

Description

Multiple format string vulnerabilities in the GNOME Data Access library for GNOME2 (libgda2) 1.2.1 and earlier allow attackers to execute arbitrary code.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 130698 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE LINUX 10.0
  • libgda >= 1.3.91-5.4
  • libgda-devel >= 1.3.91-5.4
SuSE Linux 9.0 for AMD64
SuSE Linux 9.0 for IA32
  • libgda >= 0.91.0-90
  • libgda-devel >= 0.91.0-90
SUSE LINUX 9.1 for IA32
SUSE LINUX 9.1 for x86-64
  • libgda >= 1.0.3-54.4
  • libgda-devel >= 1.0.3-54.4
SUSE LINUX 9.2
  • libgda >= 1.0.3-58.2
  • libgda-devel >= 1.0.3-58.2
SUSE LINUX 9.3
  • libgda >= 1.2.0-5.2
  • libgda-devel >= 1.2.0-5.2
Novell Linux Desktop 9 for x86
Novell Linux Desktop 9 for x86_64
Open Enterprise Server
  • libgda >= 1.0.3-54.4
  • libgda-devel >= 1.0.3-54.4
suse91.s390
suse91.ppc
sles9-oes.x86
suse91.x86-64
suse91.ia64
YOU Patch Nr: 10554