Upstream information

CVE-2005-2498 at MITRE

Description

Eval injection vulnerability in PHPXMLRPC 1.1.1 and earlier (PEAR XML-RPC for PHP), as used in multiple products including (1) Drupal, (2) phpAdsNew, (3) phpPgAds, and (4) phpgroupware, allows remote attackers to execute arbitrary PHP code via certain nested XML tags in a PHP document that should not be nested, which are injected into an eval function call, a different vulnerability than CVE-2005-1921.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entry: 104403 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE LINUX 9.3
  • apache2-mod_php5 >= 5.0.3-14.9
  • php5 >= 5.0.3-14.9
  • php5-devel >= 5.0.3-14.9
  • php5-exif >= 5.0.3-14.9
  • php5-fastcgi >= 5.0.3-14.9
  • php5-pear >= 5.0.3-14.9
  • php5-sysvmsg >= 5.0.3-14.9
  • php5-sysvshm >= 5.0.3-14.9
SUSE LINUX 9.3
  • apache2-mod_php4 >= 4.3.10-14.11
  • mod_php4-servlet >= 4.3.10-14.11
  • php4 >= 4.3.10-14.11
  • php4-32bit >= 9.3-7.5
  • php4-devel >= 4.3.10-14.11
  • php4-exif >= 4.3.10-14.11
  • php4-fastcgi >= 4.3.10-14.11
  • php4-pear >= 4.3.10-14.11
  • php4-session >= 4.3.10-14.11
  • php4-sysvshm >= 4.3.10-14.11
Open Enterprise Server
  • apache-mod_php4 >= 4.3.4-43.41
  • apache2-mod_php4 >= 4.3.4-43.41
  • mod_php4-core >= 4.3.4-43.41
  • mod_php4-servlet >= 4.3.4-43.41
  • php4 >= 4.3.4-43.41
  • php4-devel >= 4.3.4-43.41
  • php4-exif >= 4.3.4-43.41
  • php4-fastcgi >= 4.3.4-43.41
  • php4-imap >= 4.3.4-43.41
  • php4-mysql >= 4.3.4-43.41
  • php4-pear >= 4.3.4-43.41
  • php4-servlet >= 4.3.4-43.41
  • php4-session >= 4.3.4-43.41
  • php4-sysvshm >= 4.3.4-43.41
Builds
YOU Patch Nr: 10454
Open Enterprise Server
  • apache-mod_php4 >= 4.3.4-43.44
  • apache2-mod_php4 >= 4.3.4-43.44
  • mod_php4-core >= 4.3.4-43.44
  • mod_php4-servlet >= 4.3.4-43.44
  • php4 >= 4.3.4-43.44
  • php4-devel >= 4.3.4-43.44
  • php4-exif >= 4.3.4-43.44
  • php4-fastcgi >= 4.3.4-43.44
  • php4-imap >= 4.3.4-43.44
  • php4-mysql >= 4.3.4-43.44
  • php4-pear >= 4.3.4-43.44
  • php4-servlet >= 4.3.4-43.44
  • php4-session >= 4.3.4-43.44
  • php4-sysvshm >= 4.3.4-43.44
sles9-nlpos.x86
suse91.x86-64
suse91.ppc
suse91.s390
YOU Patch Nr: 10473
SUSE Linux Enterprise Server 10 SP1 for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP1 for IBM POWER
SUSE Linux Enterprise Server 10 SP1 for IBM zSeries 64bit
SUSE Linux Enterprise Server 10 SP1 for IPF
SUSE Linux Enterprise Server 10 SP1 for x86
  • php5-suhosin >= 5.1.2-29.35
sles10.x86
sles10.s390x
ZYPP Patch Nr: 2875
SUSE LINUX 9.3
  • apache2-mod_php5 >= 5.0.3-14.11
  • php5 >= 5.0.3-14.11
  • php5-devel >= 5.0.3-14.11
  • php5-exif >= 5.0.3-14.11
  • php5-fastcgi >= 5.0.3-14.11
  • php5-pear >= 5.0.3-14.11
  • php5-sysvmsg >= 5.0.3-14.11
  • php5-sysvshm >= 5.0.3-14.11
SUSE LINUX 9.3
  • apache2-mod_php4 >= 4.3.10-14.9
  • mod_php4-servlet >= 4.3.10-14.9
  • php4 >= 4.3.10-14.9
  • php4-32bit >= 9.3-7.4
  • php4-devel >= 4.3.10-14.9
  • php4-exif >= 4.3.10-14.9
  • php4-fastcgi >= 4.3.10-14.9
  • php4-pear >= 4.3.10-14.9
  • php4-session >= 4.3.10-14.9
  • php4-sysvshm >= 4.3.10-14.9