Upstream information

CVE-2005-2265 at MITRE

Description

Firefox before 1.0.5, Mozilla before 1.7.9, and Netscape 8.0.2 and 7.2 allows remote attackers to cause a denial of service (access violation and crash), and possibly execute arbitrary code, by calling InstallVersion.compareTo with an object instead of a string.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 88509 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE LINUX Retail Solution 8
SuSE Linux Enterprise Server 8 for AMD64
SuSE Linux Enterprise Server 8 for IBM iSeries and IBM pSeries
SuSE Linux Enterprise Server 8 for IBM zSeries
SuSE Linux Enterprise Server 8 for IPF
SuSE Linux Openexchange Server 4
SuSE Linux School Server for i386
SuSE Linux Standard Server 8
UnitedLinux 1.0
  • mozilla >= 1.7.8-15
  • mozilla-calendar >= 1.7.8-15
  • mozilla-devel >= 1.7.8-15
  • mozilla-dom-inspector >= 1.7.8-15
  • mozilla-irc >= 1.7.8-15
  • mozilla-mail >= 1.7.8-15
  • mozilla-spellchecker >= 1.7.8-15
  • mozilla-venkman >= 1.7.8-15
  • mozilla-xmlterm >= 1.7.8-15
slox4,2.x86
YOU Patch Nr: 10391
SuSE Linux Desktop 1.0
  • mozilla >= 1.7.8-19
  • mozilla-deat >= 1.7.6-4
  • mozilla-irc >= 1.7.8-19
  • mozilla-mail >= 1.7.8-19
Builds
SUSE LINUX 10.0
SUSE LINUX 9.2
SUSE LINUX 9.3
  • MozillaThunderbird >= 1.0.8-0.2
SUSE LINUX 9.1 for IA32
SUSE LINUX 9.1 for x86-64
  • MozillaThunderbird >= 1.0.8-0.1