Upstream information

CVE-2005-2095 at MITRE

Description

options_identities.php in SquirrelMail 1.4.4 and earlier uses the extract function to process the $_POST variable, which allows remote attackers to modify or read the preferences of other users, conduct cross-site scripting XSS) attacks, and write arbitrary files.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
SUSE Bugzilla entry: 94945 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SuSE Linux 9.0 for AMD64
SuSE Linux 9.0 for IA32
  • squirrelmail >= 1.4.1-244
SUSE LINUX 9.1 for IA32
SUSE LINUX 9.1 for x86-64
  • squirrelmail >= 1.4.2-55.9
SUSE LINUX 9.2
  • squirrelmail >= 1.4.2-59.7
SUSE LINUX 9.3
  • squirrelmail >= 1.4.2-64.5