Upstream information

CVE-2005-1410 at MITRE

Description

The tsearch2 module in PostgreSQL 7.4 through 8.0.x declares the (1) dex_init, (2) snb_en_init, (3) snb_ru_init, (4) spell_init, and (5) syn_init functions as "internal" even when they do not take an internal argument, which allows attackers to cause a denial of service (application crash) and possibly have other impacts via SQL commands that call other functions that accept internal arguments.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.1
Vector AV:L/AC:L/Au:N/C:N/I:N/A:P
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entries: 81678, 82869 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Novell Linux Desktop 9 for x86
Novell Linux Desktop 9 for x86_64
Open Enterprise Server
  • postgresql >= 7.4.8-0.6
  • postgresql-contrib >= 7.4.8-0.6
  • postgresql-devel >= 7.4.8-0.6
  • postgresql-docs >= 7.4.8-0.6
  • postgresql-libs >= 7.4.8-0.6
  • postgresql-pl >= 7.4.8-0.6
  • postgresql-server >= 7.4.8-0.6
suse91.s390
suse91.ia64
suse91.x86
suse91.ppc
YOU Patch Nr: 10230
SUSE LINUX 9.1 for IA32
  • postgresql >= 7.4.8-0.6
  • postgresql-contrib >= 7.4.8-0.6
  • postgresql-devel >= 7.4.8-0.6
  • postgresql-docs >= 7.4.8-0.6
  • postgresql-libs >= 7.4.8-0.6
  • postgresql-pl >= 7.4.8-0.6
  • postgresql-server >= 7.4.8-0.6
SUSE LINUX 9.1 for x86-64
  • postgresql >= 7.4.8-0.6
  • postgresql-contrib >= 7.4.8-0.6
  • postgresql-devel >= 7.4.8-0.6
  • postgresql-docs >= 7.4.8-0.6
  • postgresql-libs >= 7.4.8-0.6
  • postgresql-libs-32bit >= 9.1-200506061950
  • postgresql-pl >= 7.4.8-0.6
  • postgresql-server >= 7.4.8-0.6
SUSE LINUX 9.2
  • postgresql >= 7.4.8-0.3
  • postgresql-contrib >= 7.4.8-0.3
  • postgresql-devel >= 7.4.8-0.3
  • postgresql-docs >= 7.4.8-0.3
  • postgresql-libs >= 7.4.8-0.3
  • postgresql-libs-32bit >= 9.2-200506062019
  • postgresql-pl >= 7.4.8-0.3
  • postgresql-server >= 7.4.8-0.3
SUSE LINUX 9.3
  • postgresql >= 8.0.3-1.2
  • postgresql-contrib >= 8.0.3-1.2
  • postgresql-devel >= 8.0.3-1.2
  • postgresql-docs >= 8.0.3-1.2
  • postgresql-libs >= 8.0.3-1.2
  • postgresql-libs-32bit >= 9.3-7.2
  • postgresql-pl >= 8.0.3-1.2
  • postgresql-server >= 8.0.3-1.2