Upstream information

CVE-2019-5164 at MITRE

Description

An exploitable code execution vulnerability exists in the ss-manager binary of Shadowsocks-libev 3.3.2. Specially crafted network packets sent to ss-manager can cause an arbitrary binary to run, resulting in code execution and privilege escalation. An attacker can send network packets to trigger this vulnerability.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having low severity.

SUSE Bugzilla entry: 1158365 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 15.1
  • libshadowsocks-libev2 >= 3.3.3-lp151.2.3.1
  • libshadowsocks-libev2-debuginfo >= 3.3.3-lp151.2.3.1
  • shadowsocks-libev >= 3.3.3-lp151.2.3.1
  • shadowsocks-libev-debuginfo >= 3.3.3-lp151.2.3.1
  • shadowsocks-libev-debugsource >= 3.3.3-lp151.2.3.1
  • shadowsocks-libev-devel >= 3.3.3-lp151.2.3.1
  • shadowsocks-libev-doc >= 3.3.3-lp151.2.3.1
Patchnames:
openSUSE-2019-2667