Upstream information

CVE-2017-6440 at MITRE

Description

The parse_data_node function in bplist.c in libimobiledevice libplist 1.12 allows local users to cause a denial of service (memory allocation error) via a crafted plist file.

SUSE information

CVSS v2 Scores
  National Vulnerability Database
Base Score 1.85
Vector AV:L/AC:M/Au:N/C:N/I:N/A:P
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 5
Vector AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:H
Access Vector Local
Access Complexity Low
Privileges Required Low
User Interaction Required
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High

This issue is currently rated as having moderate severity.

SUSE Bugzilla entries: 1029631 [RESOLVED / ], 1029706 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • libplist >= 1.8-10.9.1
  • libplist++1 >= 1.8-10.9.1
  • libplist1 >= 1.8-10.9.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2017-835
SUSE Linux Enterprise Desktop 12 SP2
  • libplist >= 1.12-19.1
  • libplist++3 >= 1.12-19.1
  • libplist3 >= 1.12-19.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-849
SUSE Linux Enterprise Server 12 SP1
  • libplist >= 1.8-10.9.1
  • libplist1 >= 1.8-10.9.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-835
SUSE Linux Enterprise Server 12 SP2
  • libplist >= 1.12-19.1
  • libplist3 >= 1.12-19.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-849
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libplist >= 1.12-19.1
  • libplist3 >= 1.12-19.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-849
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libplist >= 1.8-10.9.1
  • libplist++-devel >= 1.8-10.9.1
  • libplist++1 >= 1.8-10.9.1
  • libplist-devel >= 1.8-10.9.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2017-835
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libplist >= 1.8-10.9.1
  • libplist++-devel >= 1.12-19.1
  • libplist++1 >= 1.8-10.9.1
  • libplist-devel >= 1.12-19.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-835
SUSE-SLE-SDK-12-SP2-2017-849
SUSE Linux Enterprise Workstation Extension 12 SP1
  • libplist >= 1.8-10.9.1
  • libplist++1 >= 1.8-10.9.1
Patchnames:
SUSE-SLE-WE-12-SP1-2017-835
SUSE Linux Enterprise Workstation Extension 12 SP2
  • libplist >= 1.12-19.1
  • libplist++3 >= 1.12-19.1
Patchnames:
SUSE-SLE-WE-12-SP2-2017-849
openSUSE Leap 42.2
  • libplist >= 1.12-7.3.1
  • libplist++-devel >= 1.12-7.3.1
  • libplist++3 >= 1.12-7.3.1
  • libplist++3-32bit >= 1.12-7.3.1
  • libplist++3-debuginfo >= 1.12-7.3.1
  • libplist++3-debuginfo-32bit >= 1.12-7.3.1
  • libplist-debugsource >= 1.12-7.3.1
  • libplist-devel >= 1.12-7.3.1
  • libplist3 >= 1.12-7.3.1
  • libplist3-32bit >= 1.12-7.3.1
  • libplist3-debuginfo >= 1.12-7.3.1
  • libplist3-debuginfo-32bit >= 1.12-7.3.1
  • plistutil >= 1.12-7.3.1
  • plistutil-debuginfo >= 1.12-7.3.1
  • python-plist >= 1.12-7.3.1
  • python-plist-debuginfo >= 1.12-7.3.1
Patchnames:
openSUSE-2017-627


List of planned updates

The following information is the current evaluation information for this security issue. It might neither be accurate nor complete, Use at own risk.
Product(s) Source package
  • SUSE Linux Enterprise Desktop 12 SP2
  • SUSE Linux Enterprise SDK 12 SP2
  • SUSE Linux Enterprise Server 12 GA
  • SUSE Linux Enterprise Server 12 SP2
  • SUSE Linux Enterprise Server for SAP 12 GA
  • SUSE Linux Enterprise Server for SAP 12 SP1
  • SUSE Linux Enterprise Server for SAP 12 SP2
  • SUSE Linux Enterprise Workstation Extension 12 SP2
libplist