Upstream information

CVE-2017-3157 at MITRE

Description

By exploiting the way Apache OpenOffice before 4.1.4 renders embedded objects, an attacker could craft a document that allows reading in a file from the user's filesystem. Information could be retrieved by the attacker by, e.g., using hidden sections to store the information, tricking the user into saving the document and convincing the user to send the document back to the attacker. The vulnerability is mitigated by the need for the attacker to know the precise file path in the target system, and the need to trick the user into saving the document and sending it back.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.3 1.9
Vector AV:N/AC:M/Au:N/C:P/I:N/A:N AV:L/AC:M/Au:N/C:P/I:N/A:N
Access Vector Network Local
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact None None
Availability Impact None None
CVSS v3 Scores
  National Vulnerability Database
Base Score 5.5
Vector AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
Access Vector Local
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact None
Availability Impact None
SUSE Bugzilla entry: 1026640 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Workstation Extension 15
  • libreoffice >= 6.0.4.2-1.12
  • libreoffice-base >= 6.0.4.2-1.12
  • libreoffice-base-drivers-mysql >= 6.0.4.2-1.12
  • libreoffice-base-drivers-postgresql >= 6.0.4.2-1.12
  • libreoffice-branding-upstream >= 6.0.4.2-1.12
  • libreoffice-calc >= 6.0.4.2-1.12
  • libreoffice-calc-extensions >= 6.0.4.2-1.12
  • libreoffice-draw >= 6.0.4.2-1.12
  • libreoffice-filters-optional >= 6.0.4.2-1.12
  • libreoffice-gnome >= 6.0.4.2-1.12
  • libreoffice-gtk3 >= 6.0.4.2-1.12
  • libreoffice-icon-themes >= 6.0.4.2-1.12
  • libreoffice-impress >= 6.0.4.2-1.12
  • libreoffice-l10n-af >= 6.0.4.2-1.12
  • libreoffice-l10n-ar >= 6.0.4.2-1.12
  • libreoffice-l10n-as >= 6.0.4.2-1.12
  • libreoffice-l10n-bg >= 6.0.4.2-1.12
  • libreoffice-l10n-bn >= 6.0.4.2-1.12
  • libreoffice-l10n-br >= 6.0.4.2-1.12
  • libreoffice-l10n-ca >= 6.0.4.2-1.12
  • libreoffice-l10n-cs >= 6.0.4.2-1.12
  • libreoffice-l10n-cy >= 6.0.4.2-1.12
  • libreoffice-l10n-da >= 6.0.4.2-1.12
  • libreoffice-l10n-de >= 6.0.4.2-1.12
  • libreoffice-l10n-dz >= 6.0.4.2-1.12
  • libreoffice-l10n-el >= 6.0.4.2-1.12
  • libreoffice-l10n-en >= 6.0.4.2-1.12
  • libreoffice-l10n-eo >= 6.0.4.2-1.12
  • libreoffice-l10n-es >= 6.0.4.2-1.12
  • libreoffice-l10n-et >= 6.0.4.2-1.12
  • libreoffice-l10n-eu >= 6.0.4.2-1.12
  • libreoffice-l10n-fa >= 6.0.4.2-1.12
  • libreoffice-l10n-fi >= 6.0.4.2-1.12
  • libreoffice-l10n-fr >= 6.0.4.2-1.12
  • libreoffice-l10n-ga >= 6.0.4.2-1.12
  • libreoffice-l10n-gl >= 6.0.4.2-1.12
  • libreoffice-l10n-gu >= 6.0.4.2-1.12
  • libreoffice-l10n-he >= 6.0.4.2-1.12
  • libreoffice-l10n-hi >= 6.0.4.2-1.12
  • libreoffice-l10n-hr >= 6.0.4.2-1.12
  • libreoffice-l10n-hu >= 6.0.4.2-1.12
  • libreoffice-l10n-it >= 6.0.4.2-1.12
  • libreoffice-l10n-ja >= 6.0.4.2-1.12
  • libreoffice-l10n-kk >= 6.0.4.2-1.12
  • libreoffice-l10n-kn >= 6.0.4.2-1.12
  • libreoffice-l10n-ko >= 6.0.4.2-1.12
  • libreoffice-l10n-lt >= 6.0.4.2-1.12
  • libreoffice-l10n-lv >= 6.0.4.2-1.12
  • libreoffice-l10n-mai >= 6.0.4.2-1.12
  • libreoffice-l10n-ml >= 6.0.4.2-1.12
  • libreoffice-l10n-mr >= 6.0.4.2-1.12
  • libreoffice-l10n-nb >= 6.0.4.2-1.12
  • libreoffice-l10n-nl >= 6.0.4.2-1.12
  • libreoffice-l10n-nn >= 6.0.4.2-1.12
  • libreoffice-l10n-nr >= 6.0.4.2-1.12
  • libreoffice-l10n-nso >= 6.0.4.2-1.12
  • libreoffice-l10n-or >= 6.0.4.2-1.12
  • libreoffice-l10n-pa >= 6.0.4.2-1.12
  • libreoffice-l10n-pl >= 6.0.4.2-1.12
  • libreoffice-l10n-pt_BR >= 6.0.4.2-1.12
  • libreoffice-l10n-pt_PT >= 6.0.4.2-1.12
  • libreoffice-l10n-ro >= 6.0.4.2-1.12
  • libreoffice-l10n-ru >= 6.0.4.2-1.12
  • libreoffice-l10n-si >= 6.0.4.2-1.12
  • libreoffice-l10n-sk >= 6.0.4.2-1.12
  • libreoffice-l10n-sl >= 6.0.4.2-1.12
  • libreoffice-l10n-sr >= 6.0.4.2-1.12
  • libreoffice-l10n-ss >= 6.0.4.2-1.12
  • libreoffice-l10n-st >= 6.0.4.2-1.12
  • libreoffice-l10n-sv >= 6.0.4.2-1.12
  • libreoffice-l10n-ta >= 6.0.4.2-1.12
  • libreoffice-l10n-te >= 6.0.4.2-1.12
  • libreoffice-l10n-th >= 6.0.4.2-1.12
  • libreoffice-l10n-tn >= 6.0.4.2-1.12
  • libreoffice-l10n-tr >= 6.0.4.2-1.12
  • libreoffice-l10n-ts >= 6.0.4.2-1.12
  • libreoffice-l10n-uk >= 6.0.4.2-1.12
  • libreoffice-l10n-ve >= 6.0.4.2-1.12
  • libreoffice-l10n-xh >= 6.0.4.2-1.12
  • libreoffice-l10n-zh_CN >= 6.0.4.2-1.12
  • libreoffice-l10n-zh_TW >= 6.0.4.2-1.12
  • libreoffice-l10n-zu >= 6.0.4.2-1.12
  • libreoffice-mailmerge >= 6.0.4.2-1.12
  • libreoffice-math >= 6.0.4.2-1.12
  • libreoffice-officebean >= 6.0.4.2-1.12
  • libreoffice-pyuno >= 6.0.4.2-1.12
  • libreoffice-writer >= 6.0.4.2-1.12
  • libreoffice-writer-extensions >= 6.0.4.2-1.12
  • libreofficekit >= 6.0.4.2-1.12
Patchnames:
SUSE Linux Enterprise Workstation Extension 15 GA libreoffice
openSUSE Leap 15.0
  • libreoffice >= 6.0.4.2-lp150.1.3
  • libreoffice-base >= 6.0.4.2-lp150.1.3
  • libreoffice-base-drivers-mysql >= 6.0.4.2-lp150.1.3
  • libreoffice-branding-upstream >= 6.0.4.2-lp150.1.3
  • libreoffice-calc >= 6.0.4.2-lp150.1.3
  • libreoffice-draw >= 6.0.4.2-lp150.1.3
  • libreoffice-filters-optional >= 6.0.4.2-lp150.1.3
  • libreoffice-gnome >= 6.0.4.2-lp150.1.3
  • libreoffice-gtk3 >= 6.0.4.2-lp150.1.3
  • libreoffice-icon-themes >= 6.0.4.2-lp150.1.3
  • libreoffice-impress >= 6.0.4.2-lp150.1.3
  • libreoffice-kde4 >= 6.0.4.2-lp150.1.3
  • libreoffice-l10n-ar >= 6.0.4.2-lp150.1.3
  • libreoffice-l10n-bg >= 6.0.4.2-lp150.1.3
  • libreoffice-l10n-ca >= 6.0.4.2-lp150.1.3
  • libreoffice-l10n-cs >= 6.0.4.2-lp150.1.3
  • libreoffice-l10n-da >= 6.0.4.2-lp150.1.3
  • libreoffice-l10n-de >= 6.0.4.2-lp150.1.3
  • libreoffice-l10n-el >= 6.0.4.2-lp150.1.3
  • libreoffice-l10n-en >= 6.0.4.2-lp150.1.3
  • libreoffice-l10n-eo >= 6.0.4.2-lp150.1.3
  • libreoffice-l10n-es >= 6.0.4.2-lp150.1.3
  • libreoffice-l10n-et >= 6.0.4.2-lp150.1.3
  • libreoffice-l10n-fa >= 6.0.4.2-lp150.1.3
  • libreoffice-l10n-fi >= 6.0.4.2-lp150.1.3
  • libreoffice-l10n-fr >= 6.0.4.2-lp150.1.3
  • libreoffice-l10n-hu >= 6.0.4.2-lp150.1.3
  • libreoffice-l10n-it >= 6.0.4.2-lp150.1.3
  • libreoffice-l10n-ja >= 6.0.4.2-lp150.1.3
  • libreoffice-l10n-ko >= 6.0.4.2-lp150.1.3
  • libreoffice-l10n-lt >= 6.0.4.2-lp150.1.3
  • libreoffice-l10n-nb >= 6.0.4.2-lp150.1.3
  • libreoffice-l10n-nl >= 6.0.4.2-lp150.1.3
  • libreoffice-l10n-pl >= 6.0.4.2-lp150.1.3
  • libreoffice-l10n-pt_BR >= 6.0.4.2-lp150.1.3
  • libreoffice-l10n-ru >= 6.0.4.2-lp150.1.3
  • libreoffice-l10n-sk >= 6.0.4.2-lp150.1.3
  • libreoffice-l10n-sl >= 6.0.4.2-lp150.1.3
  • libreoffice-l10n-sv >= 6.0.4.2-lp150.1.3
  • libreoffice-l10n-uk >= 6.0.4.2-lp150.1.3
  • libreoffice-l10n-zh_CN >= 6.0.4.2-lp150.1.3
  • libreoffice-l10n-zh_TW >= 6.0.4.2-lp150.1.3
  • libreoffice-mailmerge >= 6.0.4.2-lp150.1.3
  • libreoffice-math >= 6.0.4.2-lp150.1.3
  • libreoffice-pyuno >= 6.0.4.2-lp150.1.3
  • libreoffice-writer >= 6.0.4.2-lp150.1.3
  • libreofficekit >= 6.0.4.2-lp150.1.3
Patchnames:
openSUSE Leap 15.0 GA libreoffice
openSUSE Leap 42.3
  • libreoffice >= 5.3.3.2-1.2
  • libreoffice-base >= 5.3.3.2-1.2
  • libreoffice-base-drivers-mysql >= 5.3.3.2-1.2
  • libreoffice-branding-upstream >= 5.3.3.2-1.2
  • libreoffice-calc >= 5.3.3.2-1.2
  • libreoffice-calc-extensions >= 5.3.3.2-1.2
  • libreoffice-draw >= 5.3.3.2-1.2
  • libreoffice-filters-optional >= 5.3.3.2-1.2
  • libreoffice-gnome >= 5.3.3.2-1.2
  • libreoffice-gtk3 >= 5.3.3.2-1.2
  • libreoffice-icon-theme-breeze >= 5.3.3.2-1.2
  • libreoffice-icon-theme-galaxy >= 5.3.3.2-1.2
  • libreoffice-icon-theme-hicontrast >= 5.3.3.2-1.2
  • libreoffice-icon-theme-oxygen >= 5.3.3.2-1.2
  • libreoffice-icon-theme-sifr >= 5.3.3.2-1.2
  • libreoffice-icon-theme-tango >= 5.3.3.2-1.2
  • libreoffice-impress >= 5.3.3.2-1.2
  • libreoffice-kde4 >= 5.3.3.2-1.2
  • libreoffice-l10n-cs >= 5.3.3.2-1.2
  • libreoffice-l10n-da >= 5.3.3.2-1.2
  • libreoffice-l10n-de >= 5.3.3.2-1.2
  • libreoffice-l10n-el >= 5.3.3.2-1.2
  • libreoffice-l10n-en >= 5.3.3.2-1.2
  • libreoffice-l10n-es >= 5.3.3.2-1.2
  • libreoffice-l10n-fr >= 5.3.3.2-1.2
  • libreoffice-l10n-hu >= 5.3.3.2-1.2
  • libreoffice-l10n-it >= 5.3.3.2-1.2
  • libreoffice-l10n-ja >= 5.3.3.2-1.2
  • libreoffice-l10n-pl >= 5.3.3.2-1.2
  • libreoffice-l10n-pt_BR >= 5.3.3.2-1.2
  • libreoffice-l10n-ru >= 5.3.3.2-1.2
  • libreoffice-l10n-zh_CN >= 5.3.3.2-1.2
  • libreoffice-l10n-zh_TW >= 5.3.3.2-1.2
  • libreoffice-mailmerge >= 5.3.3.2-1.2
  • libreoffice-math >= 5.3.3.2-1.2
  • libreoffice-pyuno >= 5.3.3.2-1.2
  • libreoffice-writer >= 5.3.3.2-1.2
  • libreoffice-writer-extensions >= 5.3.3.2-1.2
  • libreofficekit >= 5.3.3.2-1.2
Patchnames:
openSUSE Leap 42.3 GA libreoffice


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise BSK 12 SP1 libreoffice Already fixed
SUSE Linux Enterprise BSK 12 SP2 libreoffice Already fixed
SUSE Linux Enterprise Desktop 12 SP1 libreoffice Already fixed
SUSE Linux Enterprise Desktop 12 SP2 libreoffice Already fixed
SUSE Linux Enterprise SDK 11 SP4 libreoffice Ignore
SUSE Linux Enterprise SDK 12 SP2 libreoffice Already fixed
SUSE Linux Enterprise Workstation Extension 12 SP1 libreoffice Already fixed
SUSE Linux Enterprise Workstation Extension 12 SP2 libreoffice Already fixed