Upstream information

CVE-2015-5949 at MITRE

Description

VideoLAN VLC media player 2.2.1 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted 3GP file, which triggers the freeing of arbitrary pointers.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 965227 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 42.1
  • libvlc5 >= 2.2.1-24.1
  • libvlc5-debuginfo >= 2.2.1-24.1
  • libvlccore8 >= 2.2.1-24.1
  • libvlccore8-debuginfo >= 2.2.1-24.1
  • vlc >= 2.2.1-24.1
  • vlc-debuginfo >= 2.2.1-24.1
  • vlc-debugsource >= 2.2.1-24.1
  • vlc-devel >= 2.2.1-24.1
  • vlc-gnome >= 2.2.1-24.1
  • vlc-gnome-debuginfo >= 2.2.1-24.1
  • vlc-noX >= 2.2.1-24.1
  • vlc-noX-debuginfo >= 2.2.1-24.1
  • vlc-noX-lang >= 2.2.1-24.1
  • vlc-qt >= 2.2.1-24.1
  • vlc-qt-debuginfo >= 2.2.1-24.1
Patchnames:
openSUSE-2016-213
openSUSE Tumbleweed
  • libvlc5 >= 2.2.4-11.1
  • libvlccore8 >= 2.2.4-11.1
  • vlc >= 2.2.4-11.1
  • vlc-codec-gstreamer >= 2.2.4-11.1
  • vlc-devel >= 2.2.4-11.1
  • vlc-lang >= 2.2.4-11.1
  • vlc-noX >= 2.2.4-11.1
  • vlc-qt >= 2.2.4-11.1
Patchnames:
openSUSE Tumbleweed GA libvlc5