Upstream information

CVE-2015-3226 at MITRE

Description

Cross-site scripting (XSS) vulnerability in json/encoding.rb in Active Support in Ruby on Rails 3.x and 4.1.x before 4.1.11 and 4.2.x before 4.2.2 allows remote attackers to inject arbitrary web script or HTML via a crafted Hash that is mishandled during JSON encoding.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entry: 934799 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE OpenStack Cloud 5
  • ruby2.1-rubygem-activesupport-4_1 >= 4.1.9-9.2
  • rubygem-activesupport-4_1 >= 4.1.9-9.2
Patchnames:
sleclo50sp3-rubygem-activesupport-4_1-12314
SUSE OpenStack Cloud 6
  • ruby2.1-rubygem-activesupport-4_2 >= 4.2.2-2.4
Patchnames:
SUSE OpenStack Cloud 6 GA ruby2.1-rubygem-activesupport-4_2
openSUSE Tumbleweed
  • ruby2.2-rubygem-activesupport-4_2 >= 4.2.7.1-1.1
  • ruby2.2-rubygem-activesupport-5_0 >= 5.0.0.1-1.1
  • ruby2.2-rubygem-activesupport-doc-4_2 >= 4.2.7.1-1.1
  • ruby2.2-rubygem-activesupport-doc-5_0 >= 5.0.0.1-1.1
  • ruby2.3-rubygem-activesupport-4_2 >= 4.2.7.1-1.1
  • ruby2.3-rubygem-activesupport-5_0 >= 5.0.0.1-1.1
  • ruby2.3-rubygem-activesupport-doc-4_2 >= 4.2.7.1-1.1
  • ruby2.3-rubygem-activesupport-doc-5_0 >= 5.0.0.1-1.1
Patchnames:
openSUSE Tumbleweed GA ruby2.2-rubygem-activesupport-4_2


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Cloud 5 rubygem-activesupport-4_1 Released
SUSE Linux Enterprise SDK 11 SP2 rubygem-activesupport-3_2 Not affected
SUSE Linux Enterprise SDK 11 SP3 rubygem-activesupport-3_2 Not affected
SUSE Linux Enterprise SDK 11 SP4 rubygem-activesupport-3_2 Not affected