Upstream information

CVE-2015-1229 at MITRE

Description

net/http/proxy_client_socket.cc in Google Chrome before 41.0.2272.76 does not properly handle a 407 (aka Proxy Authentication Required) HTTP status code accompanied by a Set-Cookie header, which allows remote proxy servers to conduct cookie-injection attacks via a crafted response.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entry: 920825 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 13.1
  • chromedriver >= 41.0.2272.76-72.1
  • chromedriver-debuginfo >= 41.0.2272.76-72.1
  • chromium >= 41.0.2272.76-72.1
  • chromium-debuginfo >= 41.0.2272.76-72.1
  • chromium-debugsource >= 41.0.2272.76-72.1
  • chromium-desktop-gnome >= 41.0.2272.76-72.1
  • chromium-desktop-kde >= 41.0.2272.76-72.1
  • chromium-ffmpegsumo >= 41.0.2272.76-72.1
  • chromium-ffmpegsumo-debuginfo >= 41.0.2272.76-72.1
Patchnames:
openSUSE-2015-228
openSUSE Leap 15.0
  • chromium >= 66.0.3359.170-lp150.1.1
Patchnames:
openSUSE Leap 15.0 GA chromium
openSUSE Tumbleweed
  • chromedriver >= 55.0.2883.75-3.1
  • chromium >= 55.0.2883.75-3.1
Patchnames:
openSUSE Tumbleweed GA chromedriver