Upstream information

CVE-2015-0862 at MITRE

Description

Multiple cross-site scripting (XSS) vulnerabilities in the management web UI in the RabbitMQ management plugin before 3.4.3 allow remote authenticated users to inject arbitrary web script or HTML via (1) message details when a message is unqueued, such as headers or arguments; (2) policy names, which are not properly handled when viewing policies; (3) details for AMQP network clients, such as the version; allow remote authenticated administrators to inject arbitrary web script or HTML via (4) user names, (5) the cluster name; or allow RabbitMQ cluster administrators to (6) modify unspecified content.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 3.5
Vector AV:N/AC:M/Au:S/C:N/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication Single
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
No SUSE Bugzilla entries cross referenced.

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE OpenStack Cloud 6
  • rabbitmq-server >= 3.4.4-2.20
  • rabbitmq-server-plugins >= 3.4.4-2.20
Patchnames:
SUSE OpenStack Cloud 6 GA rabbitmq-server
openSUSE Tumbleweed
  • erlang-rabbitmq-client >= 3.5.4-1.4
  • rabbitmq-server >= 3.5.4-1.4
  • rabbitmq-server-plugins >= 3.5.4-1.4
Patchnames:
openSUSE Tumbleweed GA erlang-rabbitmq-client