Upstream information

CVE-2014-0016 at MITRE

Description

stunnel before 5.00, when using fork threading, does not properly update the state of the OpenSSL pseudo-random number generator (PRNG), which causes subsequent children with the same process ID to use the same entropy pool and allows remote attackers to obtain private keys for EC (ECDSA) or DSA certificates.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
SUSE Bugzilla entries: 866278 [CLOSED / FIXED], 866286 [RESOLVED / INVALID]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Server Applications 15
  • stunnel >= 5.44-1.29
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 GA stunnel
SUSE Linux Enterprise Server 11-SECURITY
  • stunnel-openssl1 >= 4.54-0.11.1
Patchnames:
SUSE Linux Enterprise Server 11-SECURITY GA stunnel-openssl1
SUSE Linux Enterprise Server 12
  • stunnel >= 5.00-1.19
Patchnames:
SUSE Linux Enterprise Server 12 GA stunnel
SUSE Linux Enterprise Server 12 SP1
  • stunnel >= 5.00-3.1
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA stunnel
SUSE Linux Enterprise Server 12 SP2
  • stunnel >= 5.00-3.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA stunnel
SUSE Linux Enterprise Server 12 SP3
  • stunnel >= 5.00-3.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA stunnel
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • stunnel >= 5.00-3.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA stunnel
openSUSE Tumbleweed
  • stunnel >= 5.38-1.1
  • stunnel-doc >= 5.38-1.1
Patchnames:
openSUSE Tumbleweed GA stunnel


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Server 10 SP4 LTSS stunnel Affected
SUSE Linux Enterprise Server 11 SP1 stunnel Affected
SUSE Linux Enterprise Server 11 SP1 LTSS stunnel Affected
SUSE Linux Enterprise Server 11 SP2 stunnel Affected
SUSE Linux Enterprise Server 11 SP2 LTSS stunnel Affected
SUSE Linux Enterprise Server 11 SP3 stunnel Affected
SUSE Linux Enterprise Server 11 SP3 LTSS stunnel Affected
SUSE Linux Enterprise Server 11 SP4 stunnel Affected
SUSE Linux Enterprise Server for SAP AIO 11 SP1 stunnel Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP2 stunnel Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP3 stunnel Affected
SUSE Linux Enterprise Server for SAP ES 11 SP1 stunnel Affected
SUSE Linux Enterprise Server for VMWare 11 SP2 stunnel Affected
SUSE Linux Enterprise Server for VMWare 11 SP3 stunnel Affected