Upstream information

CVE-2012-4502 at MITRE

Description

Multiple integer overflows in pktlength.c in Chrony before 1.29 allow remote attackers to cause a denial of service (crash) via a crafted (1) REQ_SUBNETS_ACCESSED or (2) REQ_CLIENT_ACCESSES command request to the PKL_CommandLength function or crafted (3) RPY_SUBNETS_ACCESSED, (4) RPY_CLIENT_ACCESSES, (5) RPY_CLIENT_ACCESSES_BY_INDEX, or (6) RPY_MANUAL_LIST command reply to the PKL_ReplyLength function, which triggers an out-of-bounds read or buffer overflow. NOTE: versions 1.27 and 1.28 do not require authentication to exploit.

SUSE information

Overall state of this security issue: Ignore

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
No SUSE Bugzilla entries cross referenced.

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15
  • chrony >= 3.2-7.19
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA chrony
SUSE Linux Enterprise Server 12 SP2
  • chrony >= 2.3-3.110
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA chrony
SUSE Linux Enterprise Server 12 SP3
  • chrony >= 2.3-3.110
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA chrony
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • chrony >= 2.3-3.110
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA chrony
openSUSE Leap 15.0
  • chrony >= 3.2-lp150.5.5
Patchnames:
openSUSE Leap 15.0 GA chrony
openSUSE Tumbleweed
  • chrony >= 2.4.1-1.1
Patchnames:
openSUSE Tumbleweed GA chrony