Upstream information

CVE-2009-1273 at MITRE

Description

pam_ssh 1.92 and possibly other versions, as used when PAM is compiled with USE=ssh, generates different error messages depending on whether the username is valid or invalid, which makes it easier for remote attackers to enumerate usernames.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
SUSE Bugzilla entries: 492764 [RESOLVED / FIXED], 507729 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • pam_ssh >= 2.0-1.40
  • pam_ssh-32bit >= 2.0-1.40
Patchnames:
SUSE Linux Enterprise Desktop 12 GA pam_ssh
SUSE Linux Enterprise Desktop 12 SP1
  • pam_ssh >= 2.0-1.40
  • pam_ssh-32bit >= 2.0-1.40
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA pam_ssh
SUSE Linux Enterprise Desktop 12 SP2
  • pam_ssh >= 2.0-1.40
  • pam_ssh-32bit >= 2.0-1.40
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA pam_ssh
SUSE Linux Enterprise Desktop 12 SP3
  • pam_ssh >= 2.0-1.40
  • pam_ssh-32bit >= 2.0-1.40
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA pam_ssh
SUSE Linux Enterprise Module for Basesystem 15
  • pam_ssh >= 2.1-2.27
  • pam_ssh-32bit >= 2.1-2.27
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA pam_ssh
SUSE Linux Enterprise Server 12
  • pam_ssh >= 2.0-1.40
  • pam_ssh-32bit >= 2.0-1.40
Patchnames:
SUSE Linux Enterprise Server 12 GA pam_ssh
SUSE Linux Enterprise Server 12 SP1
  • pam_ssh >= 2.0-1.40
  • pam_ssh-32bit >= 2.0-1.40
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA pam_ssh
SUSE Linux Enterprise Server 12 SP2
  • pam_ssh >= 2.0-1.40
  • pam_ssh-32bit >= 2.0-1.40
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA pam_ssh
SUSE Linux Enterprise Server 12 SP3
  • pam_ssh >= 2.0-1.40
  • pam_ssh-32bit >= 2.0-1.40
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA pam_ssh
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • pam_ssh >= 2.0-1.39
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA pam_ssh
openSUSE Leap 42.1
  • pam_ssh >= 2.1-3.2
  • pam_ssh-32bit >= 2.1-3.2
Patchnames:
openSUSE Leap 42.1 GA pam_ssh
openSUSE Leap 42.2
  • pam_ssh >= 2.1-4.3
  • pam_ssh-32bit >= 2.1-4.3
Patchnames:
openSUSE Leap 42.2 GA pam_ssh
openSUSE Leap 42.3
  • pam_ssh >= 2.1-6.3
  • pam_ssh-32bit >= 2.1-6.3
Patchnames:
openSUSE Leap 42.3 GA pam_ssh
openSUSE Tumbleweed
  • pam_ssh >= 2.1-1.7
  • pam_ssh-32bit >= 2.1-1.7
Patchnames:
openSUSE Tumbleweed GA pam_ssh