Upstream information

CVE-2009-1252 at MITRE

Description

Stack-based buffer overflow in the crypto_recv function in ntp_crypto.c in ntpd in NTP before 4.2.4p7 and 4.2.5 before 4.2.5p74, when OpenSSL and autokey are enabled, allows remote attackers to execute arbitrary code via a crafted packet containing an extension field.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 501632 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • ntp >= 4.2.6p5-24.3
  • ntp-doc >= 4.2.6p5-24.3
Patchnames:
SUSE Linux Enterprise Desktop 12 GA ntp
SUSE Linux Enterprise Desktop 12 SP1
  • ntp >= 4.2.8p4-1.3
  • ntp-doc >= 4.2.8p4-1.3
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA ntp
SUSE Linux Enterprise Desktop 12 SP2
  • ntp >= 4.2.8p8-14.1
  • ntp-doc >= 4.2.8p8-14.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA ntp
SUSE Linux Enterprise Desktop 12 SP3
  • ntp >= 4.2.8p10-63.3
  • ntp-doc >= 4.2.8p10-63.3
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA ntp
SUSE Linux Enterprise Module for Legacy Software 15
  • ntp >= 4.2.8p11-2.12
Patchnames:
SUSE Linux Enterprise Module for Legacy Software 15 GA ntp
SUSE Linux Enterprise Server 11
  • ntp >= 4.2.4p6-1.17.1
  • ntp-doc >= 4.2.4p6-1.17.1
Patchnames:
slessp0-ntp
SUSE Linux Enterprise Server 11 SP1
  • ntp >= 4.2.4p8-1.3.28
  • ntp-doc >= 4.2.4p8-1.3.28
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA ntp
SUSE Linux Enterprise Server 11 SP2
  • ntp >= 4.2.4p8-1.16.1
  • ntp-doc >= 4.2.4p8-1.16.1
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA ntp
SUSE Linux Enterprise Server 11 SP3
  • ntp >= 4.2.4p8-1.22.1
  • ntp-doc >= 4.2.4p8-1.22.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA ntp
SUSE Linux Enterprise Server 11 SP4
  • ntp >= 4.2.8p2-2.18
  • ntp-doc >= 4.2.8p2-2.18
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA ntp
SUSE Linux Enterprise Server 12
  • ntp >= 4.2.6p5-24.3
  • ntp-doc >= 4.2.6p5-24.3
Patchnames:
SUSE Linux Enterprise Server 12 GA ntp
SUSE Linux Enterprise Server 12 SP1
  • ntp >= 4.2.8p4-1.3
  • ntp-doc >= 4.2.8p4-1.3
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA ntp
SUSE Linux Enterprise Server 12 SP2
  • ntp >= 4.2.8p8-14.1
  • ntp-doc >= 4.2.8p8-14.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA ntp
SUSE Linux Enterprise Server 12 SP3
  • ntp >= 4.2.8p10-63.3
  • ntp-doc >= 4.2.8p10-63.3
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA ntp
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • ntp >= 4.2.8p8-14.1
  • ntp-doc >= 4.2.8p8-14.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA ntp
SUSE Linux Enterprise Server for SAP Applications 11
  • ntp >= 4.2.4p6-1.17.1
  • ntp-doc >= 4.2.4p6-1.17.1
Patchnames:
slessp0-ntp
SUSE OpenStack Cloud 6
  • ntp >= 4.2.8p4-1.3
Patchnames:
SUSE OpenStack Cloud 6 GA ntp
SUSE Linux Enterprise SDK 10 SP2
  • xntp-doc >= 4.2.4p3-48.13.3
sles10-sp2.x86-64
sles10-sp2.s390x
sles10-sp2.ppc
sles10-sp2.x86
sle10-sp2-sdk.ia64
sles10-sp2-debuginfo.ia64
sles10-sp2-debuginfo.s390x
sles10-sp2-debuginfo.x86-64
sle10-sp2-sdk.s390x
sles10-sp2.ia64
sle10-sp2-sdk.x86
sled10-sp2.x86-64
sle10-sp2-sdk.ppc
sled10-sp2.x86
sles10-sp2-debuginfo.ppc
sle10-sp2-sdk.x86-64
sles10-sp2-debuginfo.x86
ZYPP Patch Nr: 6232
Novell Linux Desktop 9 for x86
Novell Linux Desktop 9 for x86_64
Open Enterprise Server
  • xntp >= 4.2.0a-23.20
  • xntp-doc >= 4.2.0a-23.20
core9.ia64
core9.s390
core9.ppc
sles9-oes.x86
sles9-nlpos.x86
core9.x86
core9.x86-64
sles9-nld.x86
core9.s390x
sles9-nld.x86-64
YOU Patch Nr: 12415
openSUSE 11.0
  • ntp-debuginfo >= 4.2.4p4-44.5
  • ntp-debugsource >= 4.2.4p4-44.5
openSUSE 11.0
  • ntp >= 4.2.4p4-44.5
  • ntp-doc >= 4.2.4p4-44.5
openSUSE 11.1
  • ntp-debuginfo >= 4.2.4p6-2.2.1
  • ntp-debugsource >= 4.2.4p6-2.2.1
openSUSE 11.1
  • ntp >= 4.2.4p6-2.2.1
  • ntp-doc >= 4.2.4p6-2.2.1
SUSE Linux Enterprise Desktop 11 GA
SUSE Linux Enterprise Server 11 GA
  • ntp >= 4.2.4p6-1.17.1
  • ntp-doc >= 4.2.4p6-1.17.1
sle11-debuginfo.s390x
sles11.ia64
sle11-debuginfo.x86-64
sle11-debuginfo.ia64
sles11.s390x
sled11.x86-64
sles11.x86
sles11.x86-64
sles11.ppc
sle11-debuginfo.x86
sled11.x86
sle11-debuginfo.ppc
SAT Patch Nr: 863
openSUSE Leap 42.1
  • ntp >= 4.2.8p3-7.5
  • ntp-doc >= 4.2.8p3-7.5
Patchnames:
openSUSE Leap 42.1 GA ntp
openSUSE Leap 42.2
  • ntp >= 4.2.8p8-25.1
  • ntp-doc >= 4.2.8p8-25.1
Patchnames:
openSUSE Leap 42.2 GA ntp
openSUSE Leap 42.3
  • ntp >= 4.2.8p10-30.1
  • ntp-doc >= 4.2.8p10-30.1
Patchnames:
openSUSE Leap 42.3 GA ntp
openSUSE Tumbleweed
  • ntp >= 4.2.8p9-1.1
  • ntp-doc >= 4.2.8p9-1.1
Patchnames:
openSUSE Tumbleweed GA ntp


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise 10 SP2 xntp Affected