Upstream information

CVE-2008-5587 at MITRE

Description

Directory traversal vulnerability in libraries/lib.inc.php in phpPgAdmin 4.2.1 and earlier, when register_globals is enabled, allows remote attackers to read arbitrary files via a .. (dot dot) in the _language parameter to index.php.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
SUSE Bugzilla entries: 462762 [RESOLVED / FIXED], 721976 [RESOLVED / FIXED], 754694 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 11.0
  • phpPgAdmin >= 4.2-16.2
openSUSE 11.1
  • phpPgAdmin >= 4.2-1.72.1
openSUSE 11.4
  • phpPgAdmin >= 5.0.4-66.1
Patchnames:
openSUSE-2012-219
openSUSE Tumbleweed
  • phpPgAdmin >= 5.1-5.1
Patchnames:
openSUSE Tumbleweed GA phpPgAdmin