Upstream information

CVE-2008-5500 at MITRE

Description

The layout engine in Mozilla Firefox 3.x before 3.0.5 and 2.x before 2.0.0.19, Thunderbird 2.x before 2.0.0.19, and SeaMonkey 1.x before 1.1.14 allows remote attackers to cause a denial of service (crash) and possibly trigger memory corruption via vectors related to (1) a reachable assertion or (2) an integer overflow.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 10
Vector AV:N/AC:L/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 455804 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Novell Linux Desktop 9 for x86
  • mozilla >= 1.8_seamonkey_1.0.9-1.19
  • mozilla-cs >= 1.8_seamonkey_1.0.4-0.13
  • mozilla-deat >= 1.8_seamonkey_1.0.4-0.13
  • mozilla-devel >= 1.8_seamonkey_1.0.9-1.19
  • mozilla-dom-inspector >= 1.8_seamonkey_1.0.9-1.19
  • mozilla-hu >= 1.80_seamonkey_1.0.4-11
  • mozilla-irc >= 1.8_seamonkey_1.0.9-1.19
  • mozilla-mail >= 1.8_seamonkey_1.0.9-1.19
  • mozilla-venkman >= 1.8_seamonkey_1.0.9-1.19
core9.ia64
sles9-oes.x86
sles9-nlpos.x86
core9.ppc
core9.x86
sles9-nld.x86
core9.x86-64
sles9-nld.x86-64
core9.s390
core9.s390x
YOU Patch Nr: 12326
Novell Linux Desktop 9 for x86_64
  • mozilla >= 1.8_seamonkey_1.0.9-1.19
  • mozilla-cs >= 1.8_seamonkey_1.0.4-0.13
  • mozilla-deat >= 1.8_seamonkey_1.0.4-0.13
  • mozilla-devel >= 1.8_seamonkey_1.0.9-1.19
  • mozilla-dom-inspector >= 1.8_seamonkey_1.0.9-1.19
  • mozilla-hu >= 1.80_seamonkey_1.0.4-11
  • mozilla-irc >= 1.8_seamonkey_1.0.9-1.19
  • mozilla-lib64 >= 1.8_seamonkey_1.0.9-0.8
  • mozilla-mail >= 1.8_seamonkey_1.0.9-1.19
  • mozilla-venkman >= 1.8_seamonkey_1.0.9-1.19
core9.ia64
sles9-oes.x86
sles9-nlpos.x86
core9.ppc
core9.x86
sles9-nld.x86
core9.x86-64
sles9-nld.x86-64
core9.s390
core9.s390x
YOU Patch Nr: 12326
Open Enterprise Server
  • mozilla >= 1.8_seamonkey_1.0.9-1.19
  • mozilla-calendar >= 1.8_seamonkey_1.0.9-1.19
  • mozilla-cs >= 1.8_seamonkey_1.0.4-0.13
  • mozilla-deat >= 1.8_seamonkey_1.0.4-0.13
  • mozilla-devel >= 1.8_seamonkey_1.0.9-1.19
  • mozilla-dom-inspector >= 1.8_seamonkey_1.0.9-1.19
  • mozilla-hu >= 1.80_seamonkey_1.0.4-11
  • mozilla-irc >= 1.8_seamonkey_1.0.9-1.19
  • mozilla-mail >= 1.8_seamonkey_1.0.9-1.19
  • mozilla-venkman >= 1.8_seamonkey_1.0.9-1.19
core9.ia64
sles9-oes.x86
sles9-nlpos.x86
core9.ppc
core9.x86
sles9-nld.x86
core9.x86-64
sles9-nld.x86-64
core9.s390
core9.s390x
YOU Patch Nr: 12326
openSUSE 11.0
  • seamonkey-debuginfo >= 1.1.14-0.1
  • seamonkey-debugsource >= 1.1.14-0.1
openSUSE 11.0
  • seamonkey >= 1.1.14-0.1
  • seamonkey-dom-inspector >= 1.1.14-0.1
  • seamonkey-irc >= 1.1.14-0.1
  • seamonkey-mail >= 1.1.14-0.1
  • seamonkey-spellchecker >= 1.1.14-0.1
  • seamonkey-venkman >= 1.1.14-0.1
openSUSE 11.1
  • seamonkey >= 1.1.14-1.1
  • seamonkey-debuginfo >= 1.1.14-1.1
  • seamonkey-debugsource >= 1.1.14-1.1
  • seamonkey-dom-inspector >= 1.1.14-1.1
  • seamonkey-irc >= 1.1.14-1.1
  • seamonkey-mail >= 1.1.14-1.1
  • seamonkey-spellchecker >= 1.1.14-1.1
  • seamonkey-venkman >= 1.1.14-1.1
openSUSE 11.1
  • seamonkey >= 1.1.14-1.1
  • seamonkey-dom-inspector >= 1.1.14-1.1
  • seamonkey-irc >= 1.1.14-1.1
  • seamonkey-mail >= 1.1.14-1.1
  • seamonkey-spellchecker >= 1.1.14-1.1
  • seamonkey-venkman >= 1.1.14-1.1
openSUSE 11.0
  • mozilla-xulrunner190-debuginfo >= 1.9.0.5-0.1
  • mozilla-xulrunner190-debugsource >= 1.9.0.5-0.1
openSUSE 11.0
  • mozilla-xulrunner190 >= 1.9.0.5-0.1
  • mozilla-xulrunner190-32bit >= 1.9.0.5-0.1
  • mozilla-xulrunner190-64bit >= 1.9.0.5-0.1
  • mozilla-xulrunner190-devel >= 1.9.0.5-0.1
  • mozilla-xulrunner190-gnomevfs >= 1.9.0.5-0.1
  • mozilla-xulrunner190-gnomevfs-32bit >= 1.9.0.5-0.1
  • mozilla-xulrunner190-gnomevfs-64bit >= 1.9.0.5-0.1
  • mozilla-xulrunner190-translations >= 1.9.0.5-0.1
  • mozilla-xulrunner190-translations-32bit >= 1.9.0.5-0.1
  • mozilla-xulrunner190-translations-64bit >= 1.9.0.5-0.1
openSUSE 11.1
  • mozilla-xulrunner190 >= 1.9.0.5-1.1
  • mozilla-xulrunner190-32bit >= 1.9.0.5-1.1
  • mozilla-xulrunner190-debuginfo >= 1.9.0.5-1.1
  • mozilla-xulrunner190-debugsource >= 1.9.0.5-1.1
  • mozilla-xulrunner190-devel >= 1.9.0.5-1.1
  • mozilla-xulrunner190-gnomevfs >= 1.9.0.5-1.1
  • mozilla-xulrunner190-gnomevfs-32bit >= 1.9.0.5-1.1
  • mozilla-xulrunner190-translations >= 1.9.0.5-1.1
  • mozilla-xulrunner190-translations-32bit >= 1.9.0.5-1.1
  • python-xpcom190 >= 1.9.0.5-1.1
openSUSE 11.1
  • mozilla-xulrunner190 >= 1.9.0.5-1.1
  • mozilla-xulrunner190-32bit >= 1.9.0.5-1.1
  • mozilla-xulrunner190-devel >= 1.9.0.5-1.1
  • mozilla-xulrunner190-gnomevfs >= 1.9.0.5-1.1
  • mozilla-xulrunner190-gnomevfs-32bit >= 1.9.0.5-1.1
  • mozilla-xulrunner190-translations >= 1.9.0.5-1.1
  • mozilla-xulrunner190-translations-32bit >= 1.9.0.5-1.1
  • python-xpcom190 >= 1.9.0.5-1.1
SUSE Linux Enterprise SDK 10 SP2
  • epiphany >= 1.8.5-14.7
  • gecko-sdk >= 1.8.0.14eol-0.12
sles10-sp2.x86-64
sles10-sp2.ia64
sled10-sp2.x86-64
sle10-sp2-sdk.ia64
sle10-sp2-sdk.ppc
sle10-sp2-sdk.s390x
sles10-sp2.s390x
sles10-sp2.x86
sles10-sp2.ppc
sled10-sp2.x86
sle10-sp2-sdk.x86
sle10-sp2-sdk.x86-64
ZYPP Patch Nr: 5889
openSUSE 11.0
  • MozillaThunderbird-debuginfo >= 2.0.0.19-0.1
  • MozillaThunderbird-debugsource >= 2.0.0.19-0.1
openSUSE 11.0
  • MozillaThunderbird >= 2.0.0.19-0.1
  • MozillaThunderbird-devel >= 2.0.0.19-0.1
  • MozillaThunderbird-translations >= 2.0.0.19-0.1
openSUSE 11.1
  • MozillaThunderbird >= 2.0.0.19-0.1.2
  • MozillaThunderbird-debuginfo >= 2.0.0.19-0.1.2
  • MozillaThunderbird-debugsource >= 2.0.0.19-0.1.2
  • MozillaThunderbird-devel >= 2.0.0.19-0.1.2
  • MozillaThunderbird-translations >= 2.0.0.19-0.1.2
openSUSE 11.1
  • MozillaThunderbird >= 2.0.0.19-0.1.2
  • MozillaThunderbird-devel >= 2.0.0.19-0.1.2
  • MozillaThunderbird-translations >= 2.0.0.19-0.1.2
openSUSE 11.0
  • mozilla-xulrunner181-debuginfo >= 1.8.1.19-0.1
  • mozilla-xulrunner181-debugsource >= 1.8.1.19-0.1
openSUSE 11.0
  • mozilla-xulrunner181 >= 1.8.1.19-0.1
  • mozilla-xulrunner181-32bit >= 1.8.1.19-0.1
  • mozilla-xulrunner181-64bit >= 1.8.1.19-0.1
  • mozilla-xulrunner181-devel >= 1.8.1.19-0.1
  • mozilla-xulrunner181-l10n >= 1.8.1.19-0.1
openSUSE 11.1
  • mozilla-xulrunner181 >= 1.8.1.19-1.1
  • mozilla-xulrunner181-32bit >= 1.8.1.19-1.1
  • mozilla-xulrunner181-debuginfo >= 1.8.1.19-1.1
  • mozilla-xulrunner181-debugsource >= 1.8.1.19-1.1
  • mozilla-xulrunner181-devel >= 1.8.1.19-1.1
  • mozilla-xulrunner181-l10n >= 1.8.1.19-1.1
  • mozilla-xulrunner181-l10n-32bit >= 1.8.1.19-1.1
openSUSE 11.1
  • mozilla-xulrunner181 >= 1.8.1.19-1.1
  • mozilla-xulrunner181-32bit >= 1.8.1.19-1.1
  • mozilla-xulrunner181-devel >= 1.8.1.19-1.1
  • mozilla-xulrunner181-l10n >= 1.8.1.19-1.1
  • mozilla-xulrunner181-l10n-32bit >= 1.8.1.19-1.1
openSUSE 11.0
  • MozillaFirefox-debuginfo >= 3.0.5-0.1
  • MozillaFirefox-debugsource >= 3.0.5-0.1
openSUSE 11.0
  • MozillaFirefox >= 3.0.5-0.1
  • MozillaFirefox-translations >= 3.0.5-0.1
openSUSE 11.1
  • MozillaFirefox >= 3.0.5-1.1
  • MozillaFirefox-debuginfo >= 3.0.5-1.1
  • MozillaFirefox-debugsource >= 3.0.5-1.1
  • MozillaFirefox-translations >= 3.0.5-1.1
openSUSE 11.1
  • MozillaFirefox >= 3.0.5-1.1
  • MozillaFirefox-translations >= 3.0.5-1.1
Novell Linux Desktop 9 for x86
Novell Linux Desktop 9 for x86_64
  • MozillaFirefox >= 1.5.0.12-0.17
  • MozillaFirefox-translations >= 1.5.0.12-0.17
sles9-nld.x86
sles9-nld.x86-64
YOU Patch Nr: 12325