Upstream information

CVE-2008-0983 at MITRE

Description

lighttpd 1.4.18, and possibly other versions before 1.5.0, does not properly calculate the size of a file descriptor array, which allows remote attackers to cause a denial of service (crash) via a large number of connections, which triggers an out-of-bounds access.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 364517 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Software Development Kit 11 SP4
  • lighttpd >= 1.4.20-2.54.1
  • lighttpd-mod_cml >= 1.4.20-2.54.1
  • lighttpd-mod_magnet >= 1.4.20-2.54.1
  • lighttpd-mod_mysql_vhost >= 1.4.20-2.54.1
  • lighttpd-mod_rrdtool >= 1.4.20-2.54.1
  • lighttpd-mod_trigger_b4_dl >= 1.4.20-2.54.1
  • lighttpd-mod_webdav >= 1.4.20-2.54.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA lighttpd
SUSE LINUX 10.1
  • lighttpd >= 1.4.10-11.20
  • lighttpd-mod_cml >= 1.4.10-11.20
  • lighttpd-mod_mysql_vhost >= 1.4.10-11.20
  • lighttpd-mod_rrdtool >= 1.4.10-11.20
  • lighttpd-mod_trigger_b4_dl >= 1.4.10-11.20
  • lighttpd-mod_webdav >= 1.4.10-11.20