Upstream information

CVE-2005-2869 at MITRE

Description

Multiple cross-site scripting (XSS) vulnerabilities in phpMyAdmin before 2.6.4 allow remote attackers to inject arbitrary web script or HTML via (1) the Username to libraries/auth/cookie.auth.lib.php or (2) the error parameter to error.php.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entries: 130226 [RESOLVED], 133818 [RESOLVED / FIXED], 134373 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE LINUX 10.0
  • phpMyAdmin >= 2.6.3pl1-3.3
SuSE Linux 9.0 for AMD64
SuSE Linux 9.0 for IA32
  • phpMyAdmin >= 2.5.3-41
SUSE LINUX 9.1 for IA32
SUSE LINUX 9.1 for x86-64
  • phpMyAdmin >= 2.5.6-34.11
SUSE LINUX 9.2
  • phpMyAdmin >= 2.6.0-4.11
SUSE LINUX 9.3
  • phpMyAdmin >= 2.6.1pl3-4.6
SUSE LINUX 10.0
  • phpMyAdmin >= 2.6.3pl1-3.6
SuSE Linux 9.0 for AMD64
SuSE Linux 9.0 for IA32
  • phpMyAdmin >= 2.5.3-44
SUSE LINUX 9.1 for IA32
SUSE LINUX 9.1 for x86-64
  • phpMyAdmin >= 2.5.6-34.14
SUSE LINUX 9.2
  • phpMyAdmin >= 2.6.0-4.13
SUSE LINUX 9.3
  • phpMyAdmin >= 2.6.1pl3-4.9