Upstream information

CVE-2005-0524 at MITRE

Description

The php_handle_iff function in image.c for PHP 4.2.2, 4.3.9, 4.3.10 and 5.0.3, as reachable by the getimagesize PHP function, allows remote attackers to cause a denial of service (infinite loop) via a -8 size value.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 75704 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE LINUX Retail Solution 8
SuSE Linux Enterprise Server 8 for AMD64
SuSE Linux Enterprise Server 8 for IBM iSeries and IBM pSeries
SuSE Linux Enterprise Server 8 for IBM zSeries
SuSE Linux Enterprise Server 8 for IPF
SuSE Linux Openexchange Server 4
SuSE Linux School Server for i386
SuSE Linux Standard Server 8
UnitedLinux 1.0
  • mod_php4 >= 4.2.2-491
  • mod_php4-core >= 4.2.2-491
  • mod_php4-devel >= 4.2.2-491
  • mod_php4-servlet >= 4.2.2-491
Builds
YOU Patch Nr: 10452
SUSE LINUX 9.3
  • apache2-mod_php5 >= 5.0.3-14.9
  • php5 >= 5.0.3-14.9
  • php5-devel >= 5.0.3-14.9
  • php5-exif >= 5.0.3-14.9
  • php5-fastcgi >= 5.0.3-14.9
  • php5-pear >= 5.0.3-14.9
  • php5-sysvmsg >= 5.0.3-14.9
  • php5-sysvshm >= 5.0.3-14.9
SUSE LINUX 9.3
  • apache2-mod_php4 >= 4.3.10-14.11
  • mod_php4-servlet >= 4.3.10-14.11
  • php4 >= 4.3.10-14.11
  • php4-32bit >= 9.3-7.5
  • php4-devel >= 4.3.10-14.11
  • php4-exif >= 4.3.10-14.11
  • php4-fastcgi >= 4.3.10-14.11
  • php4-pear >= 4.3.10-14.11
  • php4-session >= 4.3.10-14.11
  • php4-sysvshm >= 4.3.10-14.11
SUSE LINUX 9.3
  • apache2-mod_php4 >= 4.3.10-14.6
  • mod_php4-servlet >= 4.3.10-14.6
  • php4 >= 4.3.10-14.6
  • php4-32bit >= 9.3-7.3
  • php4-devel >= 4.3.10-14.6
  • php4-exif >= 4.3.10-14.6
  • php4-fastcgi >= 4.3.10-14.6
  • php4-pear >= 4.3.10-14.6
  • php4-session >= 4.3.10-14.6
  • php4-sysvshm >= 4.3.10-14.6
SUSE LINUX 9.3
  • apache2-mod_php5 >= 5.0.3-14.4
  • php4-exif >= 4.3.10-14.4
  • php5 >= 5.0.3-14.4
  • php5-devel >= 5.0.3-14.4
  • php5-fastcgi >= 5.0.3-14.4
  • php5-sysvmsg >= 5.0.3-14.4
  • php5-sysvshm >= 5.0.3-14.4
SUSE LINUX 9.3
  • apache2-mod_php4 >= 4.3.10-14.2
  • mod_php4-servlet >= 4.3.10-14.2
  • php4 >= 4.3.10-14.2
  • php4-32bit >= 9.3-7.1
  • php4-devel >= 4.3.10-14.2
  • php4-fastcgi >= 4.3.10-14.2
  • php4-session >= 4.3.10-14.2
  • php4-sysvshm >= 4.3.10-14.2
Open Enterprise Server
  • apache-mod_php4 >= 4.3.4-43.41
  • apache2-mod_php4 >= 4.3.4-43.41
  • mod_php4-core >= 4.3.4-43.41
  • mod_php4-servlet >= 4.3.4-43.41
  • php4 >= 4.3.4-43.41
  • php4-devel >= 4.3.4-43.41
  • php4-exif >= 4.3.4-43.41
  • php4-fastcgi >= 4.3.4-43.41
  • php4-imap >= 4.3.4-43.41
  • php4-mysql >= 4.3.4-43.41
  • php4-pear >= 4.3.4-43.41
  • php4-servlet >= 4.3.4-43.41
  • php4-session >= 4.3.4-43.41
  • php4-sysvshm >= 4.3.4-43.41
Builds
YOU Patch Nr: 10454
SUSE LINUX 9.3
  • apache2-mod_php5 >= 5.0.3-14.6
  • php5 >= 5.0.3-14.6
  • php5-devel >= 5.0.3-14.6
  • php5-exif >= 5.0.3-14.6
  • php5-fastcgi >= 5.0.3-14.6
  • php5-pear >= 5.0.3-14.6
  • php5-sysvmsg >= 5.0.3-14.6
  • php5-sysvshm >= 5.0.3-14.6
SUSE LINUX Retail Solution 8
SuSE Linux Enterprise Server 8 for AMD64
SuSE Linux Enterprise Server 8 for IBM iSeries and IBM pSeries
SuSE Linux Enterprise Server 8 for IBM zSeries
SuSE Linux Enterprise Server 8 for IPF
SuSE Linux Openexchange Server 4
SuSE Linux School Server for i386
SuSE Linux Standard Server 8
UnitedLinux 1.0
  • mod_php4 >= 4.2.2-489
  • mod_php4-core >= 4.2.2-489
  • mod_php4-devel >= 4.2.2-489
  • mod_php4-servlet >= 4.2.2-489
ul1.s390x
ul1.ia64
ul1.s390
slox4,2.x86
ul1.x86-64
ul1.ppc
YOU Patch Nr: 10035
Open Enterprise Server
  • apache-mod_php4 >= 4.3.4-43.36
  • apache2-mod_php4 >= 4.3.4-43.36
  • mod_php4-core >= 4.3.4-43.36
  • mod_php4-servlet >= 4.3.4-43.36
  • php4 >= 4.3.4-43.36
  • php4-devel >= 4.3.4-43.36
  • php4-exif >= 4.3.4-43.36
  • php4-fastcgi >= 4.3.4-43.36
  • php4-imap >= 4.3.4-43.36
  • php4-mysql >= 4.3.4-43.36
  • php4-pear >= 4.3.4-43.36
  • php4-servlet >= 4.3.4-43.36
  • php4-session >= 4.3.4-43.36
  • php4-sysvshm >= 4.3.4-43.36
suse91.x86
suse91.s390
suse91.ppc
YOU Patch Nr: 10302
Open Enterprise Server
  • apache-mod_php4 >= 4.3.4-43.44
  • apache2-mod_php4 >= 4.3.4-43.44
  • mod_php4-core >= 4.3.4-43.44
  • mod_php4-servlet >= 4.3.4-43.44
  • php4 >= 4.3.4-43.44
  • php4-devel >= 4.3.4-43.44
  • php4-exif >= 4.3.4-43.44
  • php4-fastcgi >= 4.3.4-43.44
  • php4-imap >= 4.3.4-43.44
  • php4-mysql >= 4.3.4-43.44
  • php4-pear >= 4.3.4-43.44
  • php4-servlet >= 4.3.4-43.44
  • php4-session >= 4.3.4-43.44
  • php4-sysvshm >= 4.3.4-43.44
sles9-nlpos.x86
suse91.x86-64
suse91.ppc
suse91.s390
YOU Patch Nr: 10473
SUSE LINUX 9.3
  • apache2-mod_php5 >= 5.0.3-14.2
  • php5 >= 5.0.3-14.2
  • php5-devel >= 5.0.3-14.2
  • php5-fastcgi >= 5.0.3-14.2
  • php5-sysvmsg >= 5.0.3-14.2
  • php5-sysvshm >= 5.0.3-14.2
SUSE LINUX 9.3
  • apache2-mod_php5 >= 5.0.3-14.11
  • php5 >= 5.0.3-14.11
  • php5-devel >= 5.0.3-14.11
  • php5-exif >= 5.0.3-14.11
  • php5-fastcgi >= 5.0.3-14.11
  • php5-pear >= 5.0.3-14.11
  • php5-sysvmsg >= 5.0.3-14.11
  • php5-sysvshm >= 5.0.3-14.11
SUSE LINUX Retail Solution 8
SuSE Linux Enterprise Server 8 for AMD64
SuSE Linux Enterprise Server 8 for IBM iSeries and IBM pSeries
SuSE Linux Enterprise Server 8 for IBM zSeries
SuSE Linux Enterprise Server 8 for IPF
SuSE Linux Openexchange Server 4
SuSE Linux School Server for i386
SuSE Linux Standard Server 8
UnitedLinux 1.0
  • mod_php4 >= 4.2.2-487
  • mod_php4-core >= 4.2.2-487
  • mod_php4-devel >= 4.2.2-487
  • mod_php4-servlet >= 4.2.2-487
ul1.ia64
slox4,2.x86
YOU Patch Nr: 10000
Open Enterprise Server
  • apache-mod_php4 >= 4.3.4-43.31
  • apache2-mod_php4 >= 4.3.4-43.31
  • mod_php4-core >= 4.3.4-43.31
  • mod_php4-servlet >= 4.3.4-43.31
  • php4 >= 4.3.4-43.31
  • php4-devel >= 4.3.4-43.31
  • php4-exif >= 4.3.4-43.31
  • php4-fastcgi >= 4.3.4-43.31
  • php4-imap >= 4.3.4-43.31
  • php4-mysql >= 4.3.4-43.31
  • php4-servlet >= 4.3.4-43.31
  • php4-session >= 4.3.4-43.31
  • php4-sysvshm >= 4.3.4-43.31
suse91.s390
suse91.x86-64
suse91.ppc
suse91.x86
suse91.s390x
YOU Patch Nr: 10028
SUSE LINUX Retail Solution 8
SuSE Linux Enterprise Server 8 for AMD64
SuSE Linux Enterprise Server 8 for IBM iSeries and IBM pSeries
SuSE Linux Enterprise Server 8 for IBM zSeries
SuSE Linux Enterprise Server 8 for IPF
SuSE Linux Openexchange Server 4
SuSE Linux School Server for i386
SuSE Linux Standard Server 8
UnitedLinux 1.0
  • mod_php4 >= 4.2.2-493
  • mod_php4-core >= 4.2.2-493
  • mod_php4-devel >= 4.2.2-493
  • mod_php4-servlet >= 4.2.2-493
ul1.ia64
ul1.ppc
slox4,2.x86
ul1.x86-64
ul1.s390
YOU Patch Nr: 10472
SUSE LINUX 9.3
  • apache2-mod_php4 >= 4.3.10-14.4
  • mod_php4-servlet >= 4.3.10-14.4
  • php4 >= 4.3.10-14.4
  • php4-32bit >= 9.3-7.2
  • php4-devel >= 4.3.10-14.4
  • php4-exif >= 4.3.10-14.4
  • php4-fastcgi >= 4.3.10-14.4
  • php4-session >= 4.3.10-14.4
  • php4-sysvshm >= 4.3.10-14.4
SUSE LINUX 9.3
  • apache2-mod_php5 >= 5.0.3-14.4
  • php5 >= 5.0.3-14.4
  • php5-devel >= 5.0.3-14.4
  • php5-exif >= 5.0.3-14.4
  • php5-fastcgi >= 5.0.3-14.4
  • php5-sysvmsg >= 5.0.3-14.4
  • php5-sysvshm >= 5.0.3-14.4
SUSE LINUX 9.3
  • apache2-mod_php4 >= 4.3.10-14.9
  • mod_php4-servlet >= 4.3.10-14.9
  • php4 >= 4.3.10-14.9
  • php4-32bit >= 9.3-7.4
  • php4-devel >= 4.3.10-14.9
  • php4-exif >= 4.3.10-14.9
  • php4-fastcgi >= 4.3.10-14.9
  • php4-pear >= 4.3.10-14.9
  • php4-session >= 4.3.10-14.9
  • php4-sysvshm >= 4.3.10-14.9
Open Enterprise Server
  • apache-mod_php4 >= 4.3.4-43.28
  • apache2-mod_php4 >= 4.3.4-43.28
  • mod_php4-core >= 4.3.4-43.28
  • mod_php4-servlet >= 4.3.4-43.28
  • php4 >= 4.3.4-43.28
  • php4-devel >= 4.3.4-43.28
  • php4-fastcgi >= 4.3.4-43.28
  • php4-imap >= 4.3.4-43.28
  • php4-mysql >= 4.3.4-43.28
  • php4-servlet >= 4.3.4-43.28
  • php4-session >= 4.3.4-43.28
  • php4-sysvshm >= 4.3.4-43.28
suse91.s390
suse91.ppc
suse91.x86-64
suse91.x86
suse91.s390x
YOU Patch Nr: 10004