Upstream information

CVE-2004-0983 at MITRE

Description

The CGI module in Ruby 1.6 before 1.6.8, and 1.8 before 1.8.2, allows remote attackers to cause a denial of service (infinite loop and CPU consumption) via a certain HTTP request.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entries: 214916 [RESOLVED / FIXED], 62886 [RESOLVED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE LINUX Retail Solution 8
SuSE Linux Enterprise Server 8 for AMD64
SuSE Linux Enterprise Server 8 for IBM iSeries and IBM pSeries
SuSE Linux Enterprise Server 8 for IBM zSeries
SuSE Linux Enterprise Server 8 for IPF
SuSE Linux Openexchange Server 4
SuSE Linux School Server for i386
SuSE Linux Standard Server 8
UnitedLinux 1.0
  • ruby >= 1.6.7-128
suse91.s390x
ul1.s390
slox4,2.x86
ul1.x86-64
suse91.s390
ul1.ia64
ul1.ppc
ul1.s390x
suse91.x86
suse91.x86-64
suse91.ia64
suse91.ppc
YOU Patch Nr: 9772
Novell Linux Desktop 9 for x86
  • ruby >= 1.8.1-42.4
suse91.s390x
ul1.s390
slox4,2.x86
ul1.x86-64
suse91.s390
ul1.ia64
ul1.ppc
ul1.s390x
suse91.x86
suse91.x86-64
suse91.ia64
suse91.ppc
YOU Patch Nr: 9772