Upstream information

CVE-2004-0883 at MITRE

Description

Multiple vulnerabilities in the samba filesystem (smbfs) in Linux kernel 2.4 and 2.6 allow remote samba servers to cause a denial of service (crash) or gain sensitive information from kernel memory via a samba server (1) returning more data than requested to the smb_proc_read function, (2) returning a data offset from outside the samba packet to the smb_proc_readX function, (3) sending a certain TRANS2 fragmented packet to the smb_receive_trans2 function, (4) sending a samba packet with a certain header size to the smb_proc_readX_data function, or (5) sending a certain packet based offset for the data in a packet to the smb_receive_trans2 function.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.4
Vector AV:N/AC:L/Au:N/C:P/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 61204 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SuSE Linux Enterprise Server 8 for AMD64
UnitedLinux 1.0
  • k_deflt >= 2.4.21-261
  • k_numa >= 2.4.21-261
  • k_smp >= 2.4.21-261
  • kernel-source >= 2.4.21-261
ul1.x86-64
SuSE Linux Enterprise Server 8 for IPF
UnitedLinux 1.0
  • k_deflt >= 2.4.21-261
  • k_itanium2 >= 2.4.21-261
  • k_itanium2-smp >= 2.4.21-261
  • k_smp >= 2.4.21-261
  • kernel-source >= 2.4.21-261
ul1.ia64
SuSE Linux Enterprise Server 8 for IBM zSeries
  • k_deflt >= 2.4.21-261
  • kernel-source >= 2.4.21-261
ul1.s390x
Novell Linux Desktop 9 for x86
  • kernel-bigsmp >= 2.6.5-7.111.5
  • kernel-default >= 2.6.5-7.111.5
  • kernel-smp >= 2.6.5-7.111.5
  • kernel-source >= 2.6.5-7.111.5
  • kernel-syms >= 2.6.5-7.111.5
suse91.x86
YOU Patch Nr: 9488
SuSE Linux Desktop 1.0
  • k_athlon >= 2.4.19-370
  • k_deflt >= 2.4.19-370
  • k_psmp >= 2.4.19-370
  • k_smp >= 2.4.19-370
  • kernel-source >= 2.4.19.SuSE-370
Builds
SUSE LINUX Retail Solution 8
SuSE Linux Openexchange Server 4
SuSE Linux School Server for i386
SuSE Linux Standard Server 8
UnitedLinux 1.0
  • k_athlon >= 2.4.21-261
  • k_debug >= 2.4.21-261
  • k_deflt >= 2.4.21-261
  • k_psmp >= 2.4.21-261
  • k_smp >= 2.4.21-261
  • kernel-source >= 2.4.21-261
slox4,2.x86
SuSE Linux Enterprise Server 8 for IBM iSeries and IBM pSeries
  • kernel-iseries64 >= 2.4.21-261
  • kernel-ppc64 >= 2.4.21-261
  • kernel-source >= 2.4.21-261
ul1.ppc