Upstream information

CVE-2004-0519 at MITRE

Description

Multiple cross-site scripting (XSS) vulnerabilities in SquirrelMail 1.4.2 allow remote attackers to execute arbitrary script as other users and possibly steal authentication information via multiple attack vectors, including the mailbox parameter in compose.php.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 96563 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SuSE Linux 9.0 for AMD64
SuSE Linux 9.0 for IA32
  • squirrelmail >= 1.4.1-246
SUSE LINUX 9.1 for IA32
SUSE LINUX 9.1 for x86-64
  • squirrelmail >= 1.4.2-55.11
SUSE LINUX 9.2
  • squirrelmail >= 1.4.2-59.9
SUSE LINUX 9.3
  • squirrelmail >= 1.4.2-64.7