Upstream information

CVE-2004-0394 at MITRE

Description

A "potential" buffer overflow exists in the panic() function in Linux 2.4.x, although it may not be exploitable due to the functionality of panic.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.1
Vector AV:L/AC:L/Au:N/C:P/I:N/A:N
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
SUSE Bugzilla entries: 54054, 54223 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SuSE Linux Enterprise Server 8 for IBM iSeries and IBM pSeries
  • kernel-iseries64 >= 2.4.21-215
  • kernel-ppc64 >= 2.4.21-215
  • kernel-source >= 2.4.21-215
ul1.ppc
SuSE Linux Desktop 1.0
  • k_athlon >= 2.4.19-355
  • k_deflt >= 2.4.19-355
  • k_psmp >= 2.4.19-355
  • k_smp >= 2.4.19-355
  • kernel-source >= 2.4.19.SuSE-355
Builds
SuSE Linux Enterprise Server 8 for AMD64
UnitedLinux 1.0
  • k_deflt >= 2.4.21-215
  • k_numa >= 2.4.21-215
  • k_smp >= 2.4.21-215
  • kernel-source >= 2.4.21-215
ul1.x86-64
SuSE Linux Enterprise Server 8 for IPF
UnitedLinux 1.0
  • k_deflt >= 2.4.21-215
  • k_itanium2 >= 2.4.21-215
  • k_itanium2-smp >= 2.4.21-215
  • k_smp >= 2.4.21-215
  • kernel-source >= 2.4.21-215
ul1.ia64
SUSE LINUX Retail Solution 8
SuSE Linux Openexchange Server 4
SuSE Linux School Server for i386
SuSE Linux Standard Server 8
UnitedLinux 1.0
  • k_athlon >= 2.4.21-215
  • k_debug >= 2.4.21-215
  • k_deflt >= 2.4.21-215
  • k_psmp >= 2.4.21-215
  • k_smp >= 2.4.21-215
  • kernel-source >= 2.4.21-215
slox4,2.x86