Upstream information

CVE-2003-0544 at MITRE

Description

OpenSSL 0.9.6 and 0.9.7 does not properly track the number of characters in certain ASN.1 inputs, which allows remote attackers to cause a denial of service (crash) via an SSL client certificate that causes OpenSSL to read past the end of a buffer when the long form is used.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entries: 207635 [RESOLVED / FIXED], 46906 [RESOLVED], 47556 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SuSE Linux Enterprise Server 7 for IA32
  • openssl >= 0.9.6a-83
ul1.ppc
slox4,2.x86
ul1.x86-64
ul1.ia64
ul1.s390x
ul1.s390
SuSE Linux Desktop 1.0
SuSE Linux Openexchange Server 4
SuSE Linux Standard Server 8
UnitedLinux 1.0
  • openssl >= 0.9.6g-99
ul1.ppc
slox4,2.x86
ul1.x86-64
ul1.ia64
ul1.s390x
ul1.s390
SuSE Linux Enterprise Server 8 for IPF
UnitedLinux 1.0
  • openssl >= 0.9.6g-72
ul1.ppc
slox4,2.x86
ul1.x86-64
ul1.ia64
ul1.s390x
ul1.s390
SuSE Linux Enterprise Server 8 for IBM iSeries and IBM pSeries
  • openssl >= 0.9.6g-65
ul1.ppc
slox4,2.x86
ul1.x86-64
ul1.ia64
ul1.s390x
ul1.s390
SuSE Linux Enterprise Server 8 for IBM zSeries
  • openssl >= 0.9.6g-53
ul1.ppc
slox4,2.x86
ul1.x86-64
ul1.ia64
ul1.s390x
ul1.s390
SuSE Linux Enterprise Server 8 for AMD64
UnitedLinux 1.0
  • openssl >= 0.9.6g-111
ul1.ppc
slox4,2.x86
ul1.x86-64
ul1.ia64
ul1.s390x
ul1.s390
SuSE Linux Openexchange Server 4
SuSE Linux Standard Server 8
UnitedLinux 1.0
  • openssl-devel >= 0.9.6g-99
ul1.s390x
slox4,2.x86
ul1.x86-64
ul1.s390
ul1.ia64
ul1.ppc
SuSE Linux Enterprise Server 8 for IPF
UnitedLinux 1.0
  • openssl-devel >= 0.9.6g-72
ul1.s390x
slox4,2.x86
ul1.x86-64
ul1.s390
ul1.ia64
ul1.ppc
SuSE Linux Enterprise Server 8 for IBM iSeries and IBM pSeries
  • openssl-devel >= 0.9.6g-65
ul1.s390x
slox4,2.x86
ul1.x86-64
ul1.s390
ul1.ia64
ul1.ppc
SuSE Linux Enterprise Server 8 for IBM zSeries
  • openssl-devel >= 0.9.6g-53
ul1.s390x
slox4,2.x86
ul1.x86-64
ul1.s390
ul1.ia64
ul1.ppc
SuSE Linux Enterprise Server 8 for AMD64
UnitedLinux 1.0
  • openssl-devel >= 0.9.6g-111
ul1.s390x
slox4,2.x86
ul1.x86-64
ul1.s390
ul1.ia64
ul1.ppc