SUSE Support

Here When You Need Us

Cluster reports "High CPU load detected" (PACEMAKER)

This document (7024240) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise High Availability Extension 12
SUSE Linux Enterprise High Availability Extension 15


Situation

Sometimes the logs show entries like

   crmd[2258]: notice: throttle_check_thresholds: High CPU load detected

or

   crmd[2257]:   notice: High CPU load detected

and it appears unclear how to interpret this.

Resolution

These entries can be found on SLE 12 and later Pacemaker Clusters.

These do not use the static

   lrmd_max_children

setting anymore, but have a dynamic handling of load.

To detect the system load the crmd queries its own cib and measures the time.

And according to this time will then decrease or increase the maximum number of lrmd processes that can be run in parallel.

Cause

These messages indicate that the cluster will react a little slower, as less lrmd children will be spawned. This will only be noticable on clusters with a lot of primitives.

Also the OS system load is high at this moment. This might indicate that other issues are affecting the OS at this moment, maybe some application or exterior event.

In no case this message is an indication that there is a problem with the cluster. It is an indication that the cluster is reporting a high OS Load.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7024240
  • Creation Date: 05-Nov-2019
  • Modified Date:03-Mar-2020
    • SUSE Linux Enterprise High Availability Extension

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.