SUSE Support

Here When You Need Us

Using LDL DASD devices in SLES12 FCS and SLES12 SP1.

This document (7017519) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server 12 Service Pack 1 (SLES 12 SP1)
IBM DASD - Direct-Access Storage Devices

Situation

When a DASD system is being LDL formatted using SLES 12, the disk is activated on the  'DASD Disk Management' panel, but does not provide a warning about it's LDL formatting.

When trying to create or change the partitioning scheme using YaST, this will than error out with the following message : 'DISK_CREATE_PARTITION_PARTED_FAILED'  along with system error code : -1007

Resolution

The LDL DASD devices, unlike other types of disks, cannot be partitioned - even the partition table cannot be created on such disks and they must be used as whole.

In order to avoid those errors and aborting the installation process, do not attempt to partition the LDL DASD devices and always use them as whole.
This has been corrected for SLES 12 SP2 onward, which will correctly detect DASD devices.

Cause

YaST does not detect the LDL DASD type of the devices, and does not prevent any partitioning events on such disks, which will lead to errors at later stages of the installation.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7017519
  • Creation Date: 21-Apr-2016
  • Modified Date:03-Mar-2020
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.