SUSE Support

Here When You Need Us

sssd_be[24065]: Could not start TLS encryption. unknown error

This document (000021149) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server All Service Packs

Situation

Following message is found in journalctl

2023-06-29T07:07:17.350846+02:00 server1 sssd_be[24065]: Could not start TLS encryption. unknown error

Resolution

To get more descriptive message than "unknown error" one can enable libldap debugging.
In /etc/sssd/sssd.conf under [domain/$DOMAIN] add option:
 ldap_library_debug_level = -1
and restart sssd:
systemctl restart sssd
after the error appears in journalctl, inspect /var/log/sssd/sssd_$DOMAIN.log for further details.

Cause

The message itself is harmless and might occasionally show up in journalctl.
However, if it floods the logs, it might indicate an underlying system/network problem.  
In this example case, /var/log/sssd/sssd_$DOMAIN.log shows:
(2023-07-20 11:47:25): [be[DOMAIN]] [sss_ldap_debug] (0x4000): [RID#19241] libldap: tls_read: want=5252, got=3930
(2023-07-20 11:47:25): [be[DOMAIN]] [sss_ldap_debug] (0x4000): [RID#19241] libldap: tls_read: want=1322 error=Interrupted system call
(2023-07-20 11:47:25): [be[DOMAIN]] [sss_ldap_debug] (0x4000): [RID#19241] libldap: TLS trace: SSL_connect:error in TLSv1.3 read encrypted extensions
(2023-07-20 11:47:25): [be[DOMAIN]] [sss_ldap_debug] (0x4000): [RID#19241] libldap: TLS: can't connect: .
(2023-07-20 11:47:25): [be[DOMAIN]] [sss_ldap_debug] (0x4000): [RID#19241] libldap: ldap_err2string
(2023-07-20 11:47:25): [be[DOMAIN]] [sss_ldap_init_sys_connect_done] (0x0020): [RID#19241] ldap_install_tls failed: [Connect error] [unknown error]
indicates network related problem and packets analysis is required.
 

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000021149
  • Creation Date: 24-Jul-2023
  • Modified Date:24-Jul-2023
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.