SUSE Support

Here When You Need Us

Recover the "/var/spacewalk" directory in SUSE Manager

This document (000021110) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Manager Server 4.3

Situation

For an unknown reason, the "/var/spacewalk" directory had been lost.

Resolution

1. Stop the spacewalk service.
# spacewalk-service stop 
2. Restore the /var/spacewalk filesystem from the latest backup. The most important directories to be restored are "packages", "systems", "suse" and "rhn".

Ensure the permissions for owner and group are as follows:
drwxr-xr-x  3 wwwrun root 4096 Jan  7 12:59 packages/
drwxr-xr-x  2 wwwrun www  4096 Jan  7 12:59 rhn/
drwxr-xr-x  3 root   root 4096 Jan  7 12:59 suse/
drwxrwxr-x  2 wwwrun www  4096 Jan  7 11:58 systems/ 
Note: It is recommended to restore it to another directory, and move the above sub-directories to the target directory one by one.
3. Start the spacewalk service:
# spacewalk-service start
4. Refresh the sync for the current products and channels; either from WebUI:
 (Admin - Products - Refresh) 
... or from the CLI:
# mgr-sync refresh --refresh-channels
5. Refresh the SUMA repositories metadata:
# zypper ref --force 
6. From the client side, refresh the repositories metadata:
# zypper ref --force

Cause

"/var/spacewalk" is the local repository for all the software channel's packages, losing this directory or a part of its contents will prevent any patching operations.
 

Additional Information

For further information, refer to the following documentation https://documentation.suse.com/suma/4.3/en/suse-manager/administration/backup-restore.html

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000021110
  • Creation Date: 25-Jun-2023
  • Modified Date:26-Jun-2023
    • SUSE Manager Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.