Security update for spice

SUSE Security Update: Security update for spice
Announcement ID: SUSE-SU-2017:1837-1
Rating: important
References: #1046779
Affected Products:
  • SUSE Linux Enterprise Software Development Kit 11-SP4
  • SUSE Linux Enterprise Server 11-SP4
  • SUSE Linux Enterprise Debuginfo 11-SP4

  • An update that fixes one vulnerability is now available.

    Description:

    This update for spice fixes the following issues:

    - CVE-2017-7506: A possible buffer overflow via invalid monitor
    configurations (bsc#1046779)

    Patch Instructions:

    To install this SUSE Security Update use YaST online_update.
    Alternatively you can run the command listed for your product:

    • SUSE Linux Enterprise Software Development Kit 11-SP4:
      zypper in -t patch sdksp4-spice-13203=1
    • SUSE Linux Enterprise Server 11-SP4:
      zypper in -t patch slessp4-spice-13203=1
    • SUSE Linux Enterprise Debuginfo 11-SP4:
      zypper in -t patch dbgsp4-spice-13203=1

    To bring your system up-to-date, use "zypper patch".

    Package List:

    • SUSE Linux Enterprise Software Development Kit 11-SP4 (i586 x86_64):
      • libspice-server-devel-0.12.4-11.1
    • SUSE Linux Enterprise Server 11-SP4 (i586 x86_64):
      • libspice-server1-0.12.4-11.1
    • SUSE Linux Enterprise Debuginfo 11-SP4 (i586 x86_64):
      • spice-debuginfo-0.12.4-11.1
      • spice-debugsource-0.12.4-11.1

    References: