How to set up serial console boot for headless (no graphical) boot

This document (000019728) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 12
SUSE Linux Enterprise Server 15

Situation

KVM Guest should be fully controllable by serial console

Resolution

Add following to the xml configuration file of the kvm guest:
/etc/libviretd/qemu/<name>.xml
  <os>
    <bios useserial='yes' />

To enable boot menu:
  <os>
    <bootmenu enable='yes' timeout='3000'/>

 

Cause

While it works with UEFI boot using "legacy BIOS" the serial console works after grub has prompted the boot menu. But this might be too late e.g. in special cases like encrypted disk where grub needs to request the password.

KVM Guest has already been changed for serial support as outlined below in /etc/default/grub:

change to:

GRUB_TERMINAL="gfxterm serial"

add following line after theme definition:
GRUB_SERIAL_COMMAND="serial --unit=0 --speed=9600 --parity=no"

add console=ttyS0 to GRUB_CMDLINE_LINUX_DEFAULT

To apply changes run:
update-bootloader --refresh

Accessing console works:
virsh console --safe --force <guest_name>;

 

Additional Information

Booting from ISO works after hit return or press cursor up/down is needed to see boot menu.

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000019728
  • Creation Date: 21-Jan-2021
  • Modified Date:21-Jan-2021
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Join Our Community

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.


SUSE Customer Support Quick Reference Guide SUSE Technical Support Handbook Update Advisories
Support FAQ

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.

Go to Customer Center