Crash Kernel Boot Runs Out of Memory and Fails With Large Logical Unit Number (LUN) Configurations

This document (7016542) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 11 Service Pack 3 (SLES 11 SP3)
SUSE Linux Enterprise Server 11 Service Pack 4 (SLES 11 SP4)
SUSE Linux Enterprise Server 12

Situation

On an Integrity Superdome X with BL920s Gen8 Server Blades or an HP ProLiant DL980 G7 server running  SUSE LINUX Enterprise Server 11 SP3 and configured with a large number of logical unit numbers (which is typical with multipathing; for example, more than 250 LUN paths), the crash kernel boot may run out of memory, display output, and fail.

SUSE LINUX Enterprise Server 11 SP3 example output before the crash kernel boot unresponsiveness:

Although this has been observed on the Integrity Superdome X with BL920s Gen8 Server Blades and HP ProLiant DL980 G7 server, this could occur with any system where a large number of LUN paths can be configured.

Resolution


To avoid running out of memory booting the crash kernel on large LUN configurations, perform the following:


In  /etc/sysconfig/kdump , add the kernel command line parameter:

udevd.children-max=2

Rebuild the kdump initrd as follows:
For SUSE LINUX Enterprise Server 11, type the following command:

service boot.kdump restart

In addition, increase the crash kernel size to 768M. Larger sizes may be attempted up to the maximum of 896M, if required.

Cause

Each additional LUN requires approx. 50 KiB. If a system is connected to 100 logical devices through two FC switches, it will see 200 LUNs, increasing the required memory by 50*200 = 10,000 KiB.

Note: The exact memory consumption depends on which driver handles the LUNs, so it may be different for other HBAs

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7016542
  • Creation Date: 28-May-2015
  • Modified Date:03-Mar-2020
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Join Our Community

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.


SUSE Customer Support Quick Reference Guide SUSE Technical Support Handbook Update Advisories
Support FAQ

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.

Go to Customer Center