Recommended update for corosync

SUSE Recommended Update: Recommended update for corosync
Announcement ID: SUSE-RU-2017:2733-1
Rating: moderate
References: #1001164 #1023959 #1030437 #1032634 #1037226 #1043045 #1047862 #1047876 #1051638 #1056418 #1060767 #941910 #996230
Affected Products:
  • SUSE Linux Enterprise High Availability 12-SP1

  • An update that has 13 recommended fixes can now be installed.

    Description:


    This update for corosync provides the following fixes:

    - Ensure corosync processes are memory locked. (bsc#1037226)
    - Prefer nodelist over bindnetaddr when both are available. (bsc#1030437)
    - Set initial logging priority to a lower value to allow log filters
    configured in corosync.conf to be applied. (bsc#1023959)
    - Change default token timeout to 5 seconds in the example configuration
    file, as it is in SLES 11 SP4. (bsc#1001164)
    - Don't enable corosync service by default after package installation.
    (bsc#996230)
    - Display the reason why a cluster cannot be created. (bsc#1043045)
    - Fix some conditions in the spec files. (bsc#1047862)
    - Fix an error when tearing down a network interface. (bsc#1032634)
    - Fix a problem that was preventing corosync from starting when there are
    some IPv6 addresses in /etc/hosts. (bsc#1051638)

    Patch Instructions:

    To install this SUSE Recommended Update use YaST online_update.
    Alternatively you can run the command listed for your product:

    • SUSE Linux Enterprise High Availability 12-SP1:
      zypper in -t patch SUSE-SLE-HA-12-SP1-2017-1693=1

    To bring your system up-to-date, use "zypper patch".

    Package List:

    • SUSE Linux Enterprise High Availability 12-SP1 (ppc64le s390x x86_64):
      • corosync-2.3.5-3.17.1
      • corosync-debuginfo-2.3.5-3.17.1
      • corosync-debugsource-2.3.5-3.17.1
      • libcorosync4-2.3.5-3.17.1
      • libcorosync4-debuginfo-2.3.5-3.17.1

    References: