SUSE Support

Here When You Need Us

smbclient fails after disabling SMBv1 on Windows server

This document (7019892) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server 11 SP1

Situation

After disabling SMBv1 on a Windows server any SLES 11 server running the smbclient command to mount the Windows drive fails.

You will get the error:
"protocol negotiation failed: NT_STATUS_CONNECTION_RESET"

This is because the Windows server which has been configured to only allow SMBv2 will TCP RST the connection.

Adding "-m SMB2" parameter, to the smbclient command will result in the following error:
"Unrecognised protocol level SMB2"
 

Resolution

Since SLES 11 only supports SMBv1 upgrade to SLES 12 which has support for SMBv2.

Cause

Samba 3.6 which ships with SLES 11 does not support SMBv2. (Because of problems with durable handles.)
Samba 4.x which ships with SLES 12 does support SMBv2. (Durable handles support was added in 4.0.0)

Additional Information

Can't mount a Windows share using the mount.cifs vers= option on SLES 11
https://www.suse.com/support/kb/doc.php?id=7018804

 

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7019892
  • Creation Date: 25-May-2017
  • Modified Date:23-Feb-2021
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.