Kernel Oops Exception in ibmvfc_queuecommand+0x4c

This document (7023972) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 11 Service Pack 4 (SLES 11 SP4)
SUSE Linux Enterprise Server for SAP Applications Service Pack 4
SUSE Linux Enterprise Server for PPC64
kernel-ppc64
kernel-bigmem


Situation

After patching to or migrating to the bigmem kernel (3.0.101-108.88 or above)  seeing a kernel panic while starting up SAP HANA database.
Call Trace:
[c000005234362550] [c0000052343625e0] 0xc0000052343625e0 (unreliable)
[c000005234362600] [d0000000c2b75d0c] .ibmvfc_queuecommand+0x4c/0x80 [ibmvfc]
[c0000052343626a0] [d0000000c2312cd4] .scsi_dispatch_cmd+0x104/0x3d0 [scsi_mod]
[c000005234362740] [d0000000c231d0a4] .scsi_request_fn+0x534/0x5e0 [scsi_mod]
[c00000fffff83cf0] [c000000000061298] .icp_hv_ipi_action+0x58/0xc0
[c00000fffff83d80] [c00000000012cfa8] .handle_irq_event_percpu+0x138/0x3c0
[c00000fffff83e70] [c0000000001308f4] .handle_percpu_irq+0x84/0xd0
[c00000fffff83f00] [c000000000012a90] .__do_irq+0x200/0x270
[c00000fffff83f90] [c00000000002485c] .call_do_irq+0x14/0x24
[c0000018c9c9b9d0] [c000000000012b8c] .do_IRQ+0x8c/0x120
[c0000018c9c9ba70] [c0000000000054c8] hardware_interrupt_entry+0x18/0x1c
--- Exception: 501 at .arch_local_irq_restore+0x58/0x70
    LR = .arch_local_irq_restore+0x48/0x70
[c0000018c9c9bd60] [c000000000070ef4] .pSeries_idle+0x34/0x70 (unreliable)
[c0000018c9c9bdd0] [c000000000019864] .cpu_idle+0x184/0x2f0
[c0000018c9c9be90] [c00000000065b368] .start_secondary+0x3e4/0x524
[c0000018c9c9bf90] [c0000000000083e8] .start_secondary_prolog+0x10/0x14

Resolution

Increase the ibmvfc.max_requests=1024 (default 100). 
This needs to be larger than the number of vCPU's that are assigned to the VM.
You can add this to the kernel command line options.
     ibmvfc.max_requests=1024

Cause

The default of 100 is not sufficient with the bigmem kernel with over 100 virtual CPU's assigned to VM. 
Having only 100 in-flight I/Os is too low for such a big system.

Additional Information


Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7023972
  • Creation Date: 25-Jun-2019
  • Modified Date:03-Mar-2020
    • SUSE Linux Enterprise Server

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