Root fails to login with login incorrect

This document (7023968) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 12 Service Pack 4 (SLES 12 SP4)
SUSE Linux Enterprise Server 12 Service Pack 3 (SLES 12 SP3)

Situation

When attempting to login as root or any other user, the error message "login incorrect" appears. Some systems fail to boot entirely.

The following error messages were observed.
login: pam_unix(login:auth): check pass: user unknown
login: pam_unix(login:auth): authentication failure; logname=LOGIN uid=0 euid=0 tty=tty1 ruser= rhost=
login: FAILED LOGIN 1 FROM tty1 FOR (unknown), User not known to the underlying authentication module

Some system services may be affected with similar errors:
[FAILED] Failed to start OpenSSH Daemon.
[FAILED] Failed to start wicked AutoIPv4 supplicant service.
[FAILED] Failed to start wicked DHCPv6 supplicant service.
[FAILED] Failed to start wicked DHCPv4 supplicant service.

There was no /etc/nologin present. However, the root user is found correctly in the authentication files.
# grep root /etc/passwd
root:x:0:0:root:/root:/bin/bash

# ls -al /etc/passwd
-rw------- 1 root root 1060 Oct 26  2018 /etc/passwd

# grep passwd /etc/nsswitch.conf
passwd: compat

# getent passwd | grep root
root:x:0:0:root:/root:/bin/bash

Resolution

Change the /etc/passwd permissions from 600 to 644.
# chmod 644 /etc/passwd

Cause

Invalid permissions on the /etc/passwd file.

Additional Information


Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:7023968
  • Creation Date: 24-Jun-2019
  • Modified Date:03-Mar-2020
    • SUSE Linux Enterprise Server

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

Join Our Community

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.


SUSE Customer Support Quick Reference Guide SUSE Technical Support Handbook Update Advisories
Support FAQ

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.

Go to Customer Center