Other LibreOffice Modules

Besides Writer and Calc, LibreOffice also includes the modules Impress, Base, Draw, and Math. With these you can create presentations, design databases, draw up graphics and diagrams, and create mathematical formulas.

Using Presentations with Impress

Use LibreOffice Impress to create presentations for screen display or printing, such as slide shows or transparencies. If you have used other presentation software, you can move comfortably to Impress, which works very similarly to other presentation software.

Impress can open and save Microsoft PowerPoint presentations, which means you can exchange presentations with PowerPoint users, as long as you save your presentations in PowerPoint format.

Impress also allows you to use 3D transitions for your slides. Access the available transitions by selecting Slide Show > Slide Transitions.

You can either create a brand new presentation (without any preformatted slides) or use an existing template or presentation for your new document. Impress uses styles and templates the same way other LibreOffice modules do. A wizard leads you through the options available for creating new presentations.

Using Databases with Base

LibreOffice includes a database module called Base. Use Base to design a database to store many different kinds of information, from a simple address book or recipe file to a sophisticated document management system.

Tables, forms, queries, and reports can be created manually or using convenient wizards. For example, the Table Wizard contains a number of common fields for business and personal use. A wizard guides you through the steps to create a new database.

LibreOffice Base comes with several predefined database fields to help you create a database. A wizard guides you through the steps to create a new database. The following steps are specific to creating an address book using predefined fields, but it should be easy to use the predefined fields for any of the built-in database options. The process for creating a database can be broken into several subprocesses:

Creating a Database

  1. Click File > New > Database.

  2. Select Create a new database and click Next.

  3. Click Yes, register the database for me to make your database information available to other LibreOffice modules, select both check boxes in the bottom half of the dialog, then click Finish.

  4. Browse to the directory where you want to save the database, specify a name for the database, then click Save.

Setting Up the Database Table

  1. Click the Tables icon in the left pane and select Use Wizard to Create Table.

  2. In the Table Wizard, click Personal.

  3. The Sample tables list changes to show the predefined tables for personal use. If you had clicked Business, the list would contain predefined business tables.

    In the Sample tables list, click Addresses. The available fields for the predefined address book appear in the Available fields menu.

  4. In the Available fields menu, click the fields you want to use in your address book.

    You can select one item at a time, or you can shift-click multiple items to select them.

  5. Click the single arrow icon to move the selected items to the Selected fields menu.

    To move all available fields to the Selected fields menu, click the double right- arrow.

  6. Use the arrow keys to adjust the order of the selected fields and click Finish.

    The fields appear in the table and forms in the order in which they are listed.

Creating Graphics with Draw

Use LibreOffice Draw to create graphics and diagrams. You can save your drawings in today’s most common formats and import them into any application that lets you import graphics, including the other LibreOffice modules. You can also create Flash versions of your drawings.

Creating a Graphic

  1. Click Alt+F2 and enter oodraw to open LibreOffice Draw.

  2. Use the toolbar at the bottom of the window to create a graphic.

  3. Save the graphic.

To embed an existing Draw graphic into an LibreOffice document, select Insert > Object > OLE Object. Select Create from file and click Search to navigate to the Draw file to insert. If you insert a file as OLE object, you can easily edit the object later by double-clicking it.

Opening Draw From Other LibreOffice Modules

One particularly useful feature of Draw is the ability to open it from other LibreOffice modules so you can create a drawing that is automatically imported into your document.

  1. From an LibreOffice module (for example, from Writer), click Insert > Object > OLE Object > LibreOffice 3.x Drawing > OK. This opens Draw.

  2. Create your drawing.

  3. Click in your document, outside the Draw frame.

    The drawing is automatically inserted into your document.

Creating Mathematical Formulas with Math

It is usually difficult to include complex mathematical formulas in your documents. The LibreOffice Math equation editor lets you create formulas using operators, functions, and formatting assistants. You can then save those formulas as objects that can be imported into other documents. Math functions can be inserted into other LibreOffice documents like any other graphic object.

Using Math, you can enter your equation in three different ways:

  • Type markup in the equation editor,

  • Right-click on the equation editor and select the symbol from the context menu,

    or

  • Select a symbol from the Elements toolbox.

NOTE: Math is not a calculator. The functions it creates are graphical objects. Even if they are imported into Calc, these functions cannot be evaluated.