openSUSE 10.2 GNOME Quick Start

GNOME Quick Start

openSUSE™ provides the tools that Linux* users require in their daily activities. It comes with an easy-to-use graphical user interface (the GNOME* desktop) that communicates with the underlying Linux system to let you access and manage files, folders, and programs. openSUSE provides an integrated suite of applications for a wide range of office, multimedia, and Internet activities. The OpenOffice.org suite is also included, which allows you to edit and save files in a number of formats. Because the office suite is available for several operating systems, you can use the same data across different computing platforms.

1.0 Getting Started

When you start your system, you are usually prompted to enter your username and password. If someone else installed your system, check with your system administrator for your username and password.

After logging into GNOME for the first time, you see the GNOME desktop, which offers the following basic elements:

Desktop Icons: Access programs and features on your system by double-clicking an icon. Right-click an icon to access additional menus and options. You can add as many icons to your desktop as you want. By default, the desktop features two key icons: your personal Home folder, and a trash can for deleted items. Other icons representing devices on your computer, such as CD drives, might also be present on the desktop. If you double-click your Home folder, the Nautilus file manager starts and displays the contents of your home directory.

Bottom Panel: The desktop includes a panel across the bottom of the screen. This panel contains the Computer menu (similar to the Start menu in Windows*), the system tray, and a taskbar to display icons for all applications currently running. You can also add applications and applets to the panel for easy access.

Main Menu: Click Computer on the far left of the bottom panel to open the main menu. Commonly used applications appear in the main menu. You can also click the Show drop-down list to display your favorite applications, recently used applications, or recent documents. Click More Applications to access additional applications, listed in categories. Use the options on the right to access Help, install additional software, open the GNOME Control Center, lock your screen, log out of the desktop, or check the status of your hard drive and network connections.

System Tray: The right side of the bottom panel holds some smaller icons, including the system clock that displays the date and time, the volume control, and icons for several other helper applications.

Taskbar: By default, all started applications are displayed in the taskbar (the area in the middle of the panel between the Computer button and the system tray). You can access any started application regardless of the currently active desktop. Click an application name to open it. Right-click an application name to see options for moving, restoring, or minimizing the window.

Desktop Menu: Right-click an empty spot on the desktop to display a menu with various options. Click Create Folder to create a new folder. Use Create Launcher to create a launcher icon for an application. Provide the name of the application and the command for starting it, then select an icon to represent it. You can also change the desktop background, open a terminal, create a document, and align desktop icons.

1.1 Modifying Desktop Panels

The bottom panel can be customized to meet your individual needs, and additional panels can be configured to further personalize your desktop.

To add a new panel, right-click the bottom panel and select New Panel. To delete a panel, right-click the panel and select Delete This Panel. openSUSE requires that at least one panel be left on the desktop.

1.2 Adding and Removing Panel Icons

  1. Right-click a blank space on the panel and select Add to Panel.

  2. Browse to the desired program and double-click it to add it to the panel.

  3. Customize the program icon by right-clicking the icon and selecting Preferences.

  4. To remove a program icon from a panel, right-click the icon and select Remove From Panel.

2.0 Starting Programs

To run a program in openSUSE, click Computer on the panel to open the main menu screen. If the program you want is not in the main menu screen, click More Applications to view a list of all available applications. Navigate the submenus and click an entry to start the corresponding program.

You can also add an icon to your panel that opens a more traditional version of the main menu. Right-click a blank space on the panel, select Add to Panel, then double-click Traditional Main Menu.

If you already know the name of an application but are not sure how to start it from the main menu, use the Search field in the main menu. Click Computer, type a part of the application name in the Search field, then press . If the application is installed on your system, the name of the application appears in the Desktop Search dialog box. Click the name to start the program.

3.0 Customizing Your Desktop

You can easily add, delete, and create shortcut icons on your desktop. You can also change icon properties and the desktop background to suit your needs.

3.1 Adding Program Icons to Your Desktop

  1. Click Computer.

  2. Browse to the desired program.

  3. Click and drag the icon to the desktop and position it as desired.

To delete an icon from your desktop, simply click the program icon and press the key on your keyboard.

3.2 Changing Icon Properties

After a shortcut icon is on the desktop, you can change the icon, add an emblem emblem (a graphic image placed on the corner of the icon), configure permissions, or add a note regarding the program. This is done through the Properties dialog box.

  1. Right-click the icon and select Properties.

  2. From the tabs at the top of the dialog box, customize the icon as needed. Some options include:

    Emblems: Choose a graphic image you want associated with the icon.

    Permissions: Assign permissions for the owner, a group, or others who might be sharing this machine.

    Notes: Add notes regarding the program or its use to the icon.

  3. Click Close when you have completed your changes.

3.3 Changing the Desktop Background

  1. Right-click the background.

  2. Select Change Desktop Background.

  3. To select wallpaper from the preprogrammed images, browse to and select the desired image. After you select it, the background changes automatically.

  4. To add an image, select Add Wallpaper, browse to the desired image, then click Open.

  5. To display a colored background, select No Wallpaper from the top of the list; then, from Desktop Colors, select the fill pattern and the desired colors.

  6. Click Finish.

3.4 Using the GNOME Control Center

In addition to letting you change individual desktop elements, GNOME lets you extensively personalize your desktop. You can find more settings to adjust the overall appearance and behavior of your desktop in the GNOME Control Center. There, you can also change fonts, keyboard and mouse configurations, regional and language settings, parameters for your Internet and network usage, and more.

To start the Control Center. click Computer , then click Control Center on the right of the main menu.

4.0 Managing Files and Folders

Use the Nautilus File Manager to create and view folders and documents, run scripts, and create CDs of your data. Open Nautilus by double-clicking your Home directory icon on the desktop. The contents of your home directory are displayed.

The elements of the Nautilus window include the following:

Menu: Lets you perform most tasks.

Toolbar: Lets you quickly navigate among files and folders, and provides access to files and folders.

Location Bar: Lets you locate files, folders, and URI sites.

Side Pane: Lets you navigate or display information about the selected file or folder. Use the drop-down list to customize what is shown in the pane. The list includes ways to view information about files, perform actions on files, add emblems to files, view a history of recently visited sites, and display your files in the Tree system.

View Pane: Displays folders and files. Use the options on the View menu to increase or decrease the size of content in the view pane and to display items as a list or as icons.

Status Bar: Displays the number of items in a folder and gives the available free space. When a file is selected, the status bar displays the filename and size.

4.1 Archiving Folders

If you have files you haven’t used in a while but want to keep on your computer, you can compress the files into a tape archive (TAR) format.

  1. In the Nautilus view pane, right-click the folder you want to archive, then click Create Archive.

  2. Accept the default archive filename or provide a new name.

  3. Select a file extension from the drop-down list. Use tar.gz for the most common archive form.

  4. Specify a location for the archive file, then click Create.

To extract an archived file, right-click the file and select Extract Here.

4.2 Creating a CD/DVD

If your system has a CD or DVD read/write drive, you can use the Nautilus file manager to burn CDs and DVDs.

  1. Click Computer > More Applications Multimedia > GNOME CD/DVD Creator, or insert a blank disc and click Make Data CD/DVD or Make Audio CD/DVD..

  2. Copy the files you want to put on the CD or DVD into the Nautilus CD/DVD Creator window.

  3. Click Write to Disc.

  4. Modify information in the Write to Disc dialog box or accept the defaults, then click Write.

    The files are burned to the disc. This could take a few minutes, depending on the amount of data being burned and the speed of your burner.

You can also use the Helix* Banshee™ music player to burn audio and MP3 CDs.

4.3 Using Bookmarks

Use the Nautilus Bookmarks feature to mark your favorite folders.

  1. Select the folder or item you want to create a bookmark for.

  2. Click Bookmarks > Add Bookmark. The bookmark is added to the list, with the folder name as the bookmark name. When you bookmark a file, it is the folder that is actually bookmarked.

  3. To select an item from your Bookmarks list, click Bookmarks, then click the desired bookmark in the list.

You can also organize your Bookmarks list by clicking Bookmarks > Edit Bookmarks and making your selections in the dialog box.

To change the order of your bookmarks, click a bookmark and drag it to the desired location.

5.0 Finding Files on Your Computer

To locate files on your computer, click Computer, enter your search terms in the Search field, then press . The results are displayed in the Desktop Search dialog box.

You can use the results lists to open a file, forward it via e-mail, or display it in the file manager. Simply right-click an item in the results list and select the option you want. The options available for an item depend on the type of file it is. Clicking a file in the list displays a preview of the file and information such as the title, path, and when the file was last modified or accessed.

Use the Search menu to limit your search to files in a specific location, such as your address book or Web pages, or to display only a specific type of file in your results list. The Sort menu lets you sort the items in your results list according to name, relevance, or the date the file was last modified.

You can also access Desktop Search by clicking Computer > More Applications System > Search.

6.0 Browsing the Internet with Firefox

Firefox* is fast becoming the Web browser of choice for many. It has all the familiarity of other browsers, plus added features such as security and privacy tools.

To start Firefox, click Computer Firefox Web Browser.

With features like tabbed browsing, pop-up window blocking, and download and image management, Firefox combines the latest Web technologies. Its easy access to different search engines helps you find the information you need. Enter a URL in the location bar to start browsing.

To open an empty tab in Firefox, press + T and type a new URL. To open a link in a new tab, click the link with your middle mouse button. Right-click a tab to access more tab options. You can create a new tab, reload one or all existing tabs, or close a single tab or all tabs. You can also change the sequence of the tabs by dragging and dropping them to a new position.

6.1 Finding Information on the Web

  1. To start a search on the Web with the Google engine, type your search keywords in the integrated search box Google search bar on the right of the location bar and press . The results display in the window.

  2. To use a different search engine, click the G icon in the search box to open a list of other search engines.

  3. Click the desired engine and press to start the search.

You can also search the current Web page for keywords. To do so, press + F to open a Find bar at the bottom of the window. Enter your search keyword there and use the buttons to the right of the box to search in different directions or to select all hits in the text.

6.2 Downloading with Firefox

If you download a file with Firefox, the Firefox Download Manager starts and saves this file to the folder configured in Firefox Preferences. By default, your desktop is the destination folder for downloaded files. Firefox shows your finished downloads in the Downloads window.

You can open the downloaded files directly from the Downloads window or from the destination folder. To clean up the history of downloaded files, click Clean Up.

6.3 Configuring Firefox Preferences

To adjust the default download folder or to activate or modify the pop-up blocking feature, click Edit Preferences.

From here you can also configure numerous other settings such as appearance, language, privacy, and tab options. Click the icons and set the options on each page according to your preferences. Click Close to apply the changes.

7.0 Managing Your Music

Use Helix Banshee to import CDs, sync your music collection to an iPod*, play music directly from an iPod, create playlists with songs from your library, and create audio and MP3 CDs from subsets of your library.

To open Helix Banshee, click Computer Helix Banshee Music Player.

The first time you open Helix Banshee, click OK to accept the license agreement. You are then prompted to import music. Choose an import source, such as a local folder, local file, or your home directory, then click Import Music Source. After successfully importing your music, your library is displayed.

7.1 Playing Your Music

To play a song, simply select the song in the library and click the Play button (Banshee play button). You can also use the buttons in the upper left corner (Banshee playback buttons) to pause a song or play the next or previous song. Use Banshee volume button to adjust the volume.

Helix Banshee also has an integrated CD player. When you insert a music CD, your CD title appears in the left panel. Select the title and click the Play button to play your full CD.

7.2 Organizing Your Music

To create a new playlist, click Music New Playlist (or press + N). A new playlist is displayed in the left panel. Double-click New Playlist and enter the name you want. You can drag and drop songs from one playlist to another, or use the options on the Edit menu to remove or delete songs and rename or delete playlists.

To view the properties of a song, select a song in the library and click Edit > Edit Song Metadata. You can view the duration of a song, the number of times it has been played, when it was last played, and when it was imported.

You can edit the name of the artist, album, and title, as well as the track number and track count. If you want to set all fields in a set to the same value, select multiple songs in a playlist, then click Edit > Edit Song Metadata.

7.3 Using Helix Banshee with Your iPod

To play music from your iPod, simply plug your iPod into your system. Your iPod appears in the left panel. Select the song you want to hear, then click the Play button.

When the iPod is selected in the left panel, information about your iPod is displayed at the bottom left, including disk usage and the Sync, Properties, and Eject buttons.

There are three ways to manage the music on your iPod:

  • Manually: Browse your iPod and drag music between your library and the iPod.

  • Automatically sync: Automatically copies everything in your library to the iPod.

  • Automatic merge: All the music on your iPod that is not in your library is downloaded to your library, and all the music that is in your library and not in your iPod is uploaded to your iPod.

7.4 Creating Audio and MP3 CDs

To create audio and MP3 CDs, select the songs you want, then click the Write CD button in the upper right side of Helix Banshee.

8.0 E-Mailing and Calendaring

For reading and managing your mail and events, openSUSE offers you Novell® Evolution™, a groupware program that makes it easy to store, organize, and retrieve your personal information.

8.1 Starting Evolution for the First Time

Evolution seamlessly combines e-mail, a calendar, an address book, and a task list in one easy-to-use application. With its extensive support for communications and data interchange standards, Evolution can work with existing corporate networks and applications, including Microsoft* Exchange.

To start Evolution, click Computer More Applications > Office > Evolution Mail and Calendar.

The first time you start it, Evolution prompts you with a few questions as it sets up a mail account and helps you import mail from your old mail client. Then it shows you how many new messages you have and lists upcoming appointments and tasks, as well as the current weather and news from news feeds. The calendar, address book, and mail tools are available in the shortcut bar on the left.

8.2 Using Evolution

Press + N to open a new item for whatever part of Evolution you're working in. In mail, this creates a new message. If you're in the address book, + N creates a new contact card, and in the calendar, + N creates a new appointment.

Using Evolution E-Mail

Send and Receive Mail: Press F9, click the Get Mail button on the toolbar, or click File > Get Mail.

Navigating the Message List with the Keyboard: Press ] or . to jump to the next unread message. Press [ or , to go to the previous unread message. Use the arrow keys to move up and down the list of all messages.

Moving the Display Up and Down in the Preview Pane: Press the Spacebar to move down a page. Press Backspace to move up a page.

Replying To a Message: To reply only to the sender of the message, click Reply in the toolbar, or press R.

To reply to the sender and all the other visible recipients of the message, click Reply to All or press + R.

Forwarding a Message: Select the message or messages you want to forward, then click Forward in the toolbar, or press F.

Opening a Message In a New Window: Double-click the message you want to view, or select it and press or + O.

Creating Filters and Virtual Folders: Right-click a message and select Create Rule From Message.

Adding a Sender to the Address Book: Select a message then click Message Add Sender to Address Book. You can also right-click any e-mail address, then click Add to Address Book.

Using Evolution Calendar

Creating a New Appointment: Click File > New Appointment or press + A.

You can also click in any blank spot in the calendar and start typing to create a new appointment entry.

Creating a New Task: Click File > New Task or press + T.

Using the Evolution Address Book

Editing a Contact: Double-click the contact's address card to change details.

Deleting a Contact: Right-click a contact, then click Delete; or select a contact, then click Delete on the toolbar.

Sending E-Mail To a Contact: Right-click a contact, then click Send Message to Contact.

Creating a New Contact: Double-click any blank space in the contact manager to create a new address card, or right-click anywhere in the address book and select New Contact. You can also click File > New > Contact or press + C.

9.0 Instant Messaging with Gaim

Gaim is a multiprotocol instant messaging (IM) client for Linux, BSD, Mac OS* X, and Windows. It is compatible with GroupWise® Messenger, AOL* Instant Messenger (AIM), ICQ, Yahoo!*, IRC, Jabber*, Gadu-Gadu, and Zephyr* networks.

To configure Gaim:

  1. Click Computer > More Applications Internet > Gaim Instant Messenger.

  2. Click Accounts > Add.

  3. Select the protocol you want, then type your screen name, password, and alias in the appropriate fields.

  4. Specify any desired user options, then click Show More Options.

  5. Type your server address in the Server Address field.

  6. Type your server port (if different from the default) in the Server Port field.

  7. Select your proxy type, if needed.

  8. Click Save, then click Close in the Accounts window.

  9. Select the account you just created in the Login window.

  10. Type your password in the Password field.

  11. Click Sign On.

10.0 Starting OpenOffice.org

The OpenOffice.org office suite offers a complete set of office tools, including a word processor, spreadsheet, presentation, vector drawing, and database components. Because OpenOffice.org is available for a number of operating systems, you can use the same data across different computing platforms.

To start OpenOffice.org, click Computer OpenOffice.org Writer. To create a new document, click File > New, then choose the type of document you want to create. To open an existing document, click Open, then select the file you want from the file system.

11.0 Viewing PDF Files

Documents that need to be shared or printed across platforms can be saved as PDF (Portable Document Format) files in the OpenOffice.org suite. openSUSE ships with Evince, a document viewer that supports PDF, PostScript, DjVu, TIFF, and DVI file formats.

  1. Press + F2, enter evince, then press .

  2. To view a PDF file, click File > Open, locate the desired PDF file, then click Open.

  3. Use the navigation icons at the top of the window to navigate through the document. If your PDF document provides bookmarks, you can access them in the left panel of the viewer.

12.0 Configuring Your System with YaST

Use the YaST Control Center to change the installation and configuration of your whole system. Administrator (or root) permission is required to open YaST.

To open YaST, click Computer More Applications > System > YaST, then enter the root password. If you do not know the root password, ask your system administrator.

YaST contains various modules you can use to adjust your system settings. These modules are divided into the following categories:

Software: Use the modules of this category to set options for installation and updates and to install or remove software packages.

Hardware: Contains modules for configuring hardware components such as your monitor, keyboard, mouse, printer, and scanner.

System: Use these modules to change system settings such as the date, time, or language, and to perform tasks such as backing up or restoring files.

Network Devices: Includes modules for configuring network devices such as network cards, ISDN, DSL, or modem.

Network Services: Contains modules for network services and for configuring clients such as LDAP and NFS.

Novell AppArmor: Use the modules of this category to configure the Novell AppArmor™ access control system.

Security and Users: Use these modules to configure security details such as firewall options, and to create and manage users and groups.

Miscellaneous: The YaST Control Center has several modules that cannot easily be classified into the first six module groups. The modules in this category can be used for things such as viewing log files and installing drivers from a vendor CD.

13.0 Managing Printers

Printers can either be connected to your system locally or accessed over a network. To use a local printer, make sure that it is connected to your machine. Shut down the system before connecting a non-USB printer to your system.

You can configure printers with YaST. Start YaST, then click Hardware > Printer to open the main printer configuration window. Depending on the network environment or your local printer model, YaST might be able to configure the printer automatically. If autodetection of printing devices fails, click Add in the Printer Configuration dialog box to start the manual configuration workflow. Follow the instructions in the YaST online help. If you are not sure which option to choose and which information to enter, ask your system administrator.

After configuring a printing device correctly, you can address it from any application.

You can also use the GNOME Control Center to monitor and manage your print jobs. Click Computer > Control Center > Printers. Administrator (or root) permission is required.

14.0 Logging Out

When you are finished using the computer, click Computer > Log Out, then select one of the following options:

Log out: Logs you out of the current session and returns you to the Login screen.

Shut down: Logs you out of the current session, then turns off the computer.

Restart the computer: Logs you out of the current session, then restarts the computer.

Suspend the computer: Puts your computer in a temporary state that conserves power. The state of your session is preserved, however, including all applications you have running and all documents you have open.

15.0 For More Information

This guide gave you a short introduction to the GNOME desktop and some key applications running on it. For more information, see GNOME User Guide and the other manuals available for openSUSE at http://www.novell.com/documentation/opensuse102 or in your installed system under /usr/share/doc/manual.