SUSE Support

Here When You Need Us

crm cluster join fails. ERROR: No such file or directory: '/etc/corosync/corosync.conf'

This document (000021126) is provided subject to the disclaimer at the end of this document.

Environment

SUSE Linux Enterprise Server 15

Situation

Cluster is up on node1.  On joining node2 to the cluster it fails:
node2:~ # crm cluster join -c node1
INFO: BEGIN Configuring csync2
INFO: END Configuring csync2
INFO: Merging known_hosts
INFO: BEGIN Probing for new partitions
INFO: END Probing for new partitions
ERROR: cluster.join: [Errno 2] No such file or directory: '/etc/corosync/corosync.conf'

Resolution

Ensure Network Interface Card (NIC) names are identical on all nodes.

Cause

In this scenario, node1 has network interface eth0, but doesn't have eth1, while node2 has network interface eth1, but doesn't have eth0.

When the node2 NIC name doesn't exist on node1, the crm script fails to setup csync2 on node1.  As the result of that, /etc/corosync/corosync.conf is not copied from node1 to node2.

Status

Reported to Engineering

Additional Information

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000021126
  • Creation Date: 03-Jul-2023
  • Modified Date:26-Sep-2023
    • SUSE Linux Enterprise High Availability Extension

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.