SUSE Support

Here When You Need Us

Rancher-provisioned RKE2 clusters stuck "Waiting for kube-controller-manager/kube-scheduler probes" due to certificate expiration in Rancher < v2.7.5

This document (000021371) is provided subject to the disclaimer at the end of this document.

Environment

  • SUSE Rancher < v2.7.5
  • A Rancher-provisioned RKE2 cluster

Situation

This article explains a problem where a Rancher-provisioned RKE2 cluster gets stuck in a "Waiting for probes: kube-controller-manager, kube-scheduler" state, when running Rancher < v2.7.5. This happens because the certificates used by the kube-controller-manager and kube-scheduler components expire.

Resolution

This issue is fixed in Rancher version 2.7.5. Starting with this version, the kube-controller-manager and kube-scheduler certificates in Rancher-managed RKE2 clusters are now part of the certificate rotation. When you use Rancher's Rotate Certificates feature, these certificates will also be renewed, which stops the problem described earlier.

Workaround
For versions older than 2.7.5, as well as in exceptional cases, the suggested workaround would be as follows:
  1. Stop the RKE2 server: 
    • systemctl stop rke2-server
  2. Remove the .crt and .key file in the respective tls directories:
    1. rm /var/lib/rancher/rke2/server/tls/kube-controller-manager/kube-controller-manager.{crt,key}
    2. rm /var/lib/rancher/rke2/server/tls/kube-scheduler/kube-scheduler.{crt,key}
  3. Perform a certificate rotation: 
    • rke2 certificate rotate
  4. Restart RKE2 server: 
    • systemctl start rke2-server

Cause

RKE2's regular certificate rotation doesn't manage the certificates for the kube-controller-manager and kube-scheduler in Rancher-provisioned RKE2 clusters. Because of an issue in Rancher versions before v2.7.5, these certificates were not automatically renewed when other cluster certificates were rotated. If these certificates expire, it can stop communication between these cluster components and the kube-apiserver, leading to the "Waiting for probes" state.

Additional Information

Disclaimer

This Support Knowledgebase provides a valuable tool for SUSE customers and parties interested in our products and solutions to acquire information, ideas and learn from one another. Materials are provided for informational, personal or non-commercial use within your organization and are presented "AS IS" WITHOUT WARRANTY OF ANY KIND.

  • Document ID:000021371
  • Creation Date: 27-Feb-2024
  • Modified Date:19-Aug-2025
    • SUSE Rancher

< Back to Support Search

For questions or concerns with the SUSE Knowledgebase please contact: tidfeedback[at]suse.com

tick icon

SUSE Support Forums

Get your questions answered by experienced Sys Ops or interact with other SUSE community experts.

tick icon

Support Resources

Learn how to get the most from the technical support you receive with your SUSE Subscription, Premium Support, Academic Program, or Partner Program.

tick icon

Open an Incident

Open an incident with SUSE Technical Support, manage your subscriptions, download patches, or manage user access.